summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-07-21 16:03:11 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-07-21 16:03:11 +0000
commit7f21077a802f3d3c144b086c969d54a36775992e (patch)
tree5b44fd804510b4868126383784a8344972c1bf3f /configure.ac
parent7b80cad30fd2912dd6a50507a77296d00d66add4 (diff)
downloadgst-plugins-bad-7f21077a802f3d3c144b086c969d54a36775992e.tar.gz
gst-plugins-bad-7f21077a802f3d3c144b086c969d54a36775992e.tar.bz2
gst-plugins-bad-7f21077a802f3d3c144b086c969d54a36775992e.zip
Link the ladspa plugin with -ldl. It's needed for dlopen() and friends for loading the ladspa plugins and previously ...
Original commit message from CVS: * configure.ac: * ext/ladspa/Makefile.am: Link the ladspa plugin with -ldl. It's needed for dlopen() and friends for loading the ladspa plugins and previously was linked in by gmodule. Fixes bug #543848.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4abcf5ca..50ebcb74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -660,7 +660,15 @@ dnl *** ladspa ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LADSPA, true)
AG_GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
AC_CHECK_HEADER(ladspa.h, HAVE_LADSPA="yes", HAVE_LADSPA="no")
+ save_cflags="$CFLAGS"
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+
+ AC_CHECK_LIB(dl, dlopen,
+ LADSPA_LIBS="-ldl",
+ HAVE_LADSPA="no")
+ CFLAGS="$save_cflags"
])
+AC_SUBST(LADSPA_LIBS)
dnl *** libmms ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LIBMMS, true)