summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2002-01-17 13:03:04 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2002-01-17 13:03:04 +0000
commit82f930a0b004a0c7abd40dd90b0e97270a8e45b6 (patch)
tree70244b2e3844f4ed41069d9bfb48b2913acbcc0d /configure.ac
parent475246fc0afbed34958dcd9d4a08dd3a51df1d13 (diff)
downloadgst-plugins-bad-82f930a0b004a0c7abd40dd90b0e97270a8e45b6.tar.gz
gst-plugins-bad-82f930a0b004a0c7abd40dd90b0e97270a8e45b6.tar.bz2
gst-plugins-bad-82f930a0b004a0c7abd40dd90b0e97270a8e45b6.zip
please don't try to change what is going to be build in Makefile.am files everything is done using a USE_ conditional...
Original commit message from CVS: please don't try to change what is going to be build in Makefile.am files everything is done using a USE_ conditional, so set it to no in configure.ac if you don't want it. This one is a good example. Don't know if qcam needs nasm though : is checking for nasm a check for what hardware platform ? If so we need to change this. In any case, let's not "fix" "problems" like this because this is how cruft comes in. Keep it in a local tree and bring it up so we can fix it right ;)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 857f96cb..57a6fa03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,7 +279,16 @@ GST_CHECK_FEATURE(OSS, [OSS audio], osssrc osssink, [
dnl *** QuickCam ***
translit(dnm, m, l) AM_CONDITIONAL(USE_QCAM, true)
-GST_CHECK_FEATURE(QCAM, [QuickCam], qcamsrc, HAVE_QCAM="yes")
+GST_CHECK_FEATURE(QCAM, [QuickCam], qcamsrc, [
+dnl this one is for hadess, no qcam when no nasm found
+ if test "x$HAVE_NASM" = "xno";
+ then
+ HAVE_QCAM="no"
+ AC_MSG_WARN([QuickCam needs nasm])
+ else
+ HAVE_QCAM="yes"
+ fi
+])
dnl *** Video 4 Linux ***
translit(dnm, m, l) AM_CONDITIONAL(USE_V4L, true)