summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-11-07 18:30:06 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2004-11-07 18:30:06 +0000
commit868291efc42d7b66bfdafe0eded0b38ccad0b3b1 (patch)
treee92a7f534e4ae857d36efd030646bee667f613ba /configure.ac
parentc69f0127dfa452cedddc8e87e28b59e41eea4d9a (diff)
downloadgst-plugins-bad-868291efc42d7b66bfdafe0eded0b38ccad0b3b1.tar.gz
gst-plugins-bad-868291efc42d7b66bfdafe0eded0b38ccad0b3b1.tar.bz2
gst-plugins-bad-868291efc42d7b66bfdafe0eded0b38ccad0b3b1.zip
Add musepack decoder.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/musepack/Makefile.am: * ext/musepack/gstmusepackdec.cpp: * ext/musepack/gstmusepackdec.h: * ext/musepack/gstmusepackreader.cpp: * ext/musepack/gstmusepackreader.h: Add musepack decoder. * ext/faad/gstfaad.c: (gst_faad_base_init): Make pad templates static. * gst/typefind/gsttypefindfunctions.c: (mp3_type_find), (plugin_init): Add musepack typefinder, make mp3 typefinding work halfway stream, which doesn't actually work yet because id3demux doesn't implement _get_length().
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11b17ff0..a69a2bcd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1359,6 +1359,23 @@ main (int argc,
fi
])
+dnl *** musepack ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_MUSEPACK, true)
+GST_CHECK_FEATURE(MUSEPACK, [musepackdec], musepack, [
+ AC_LANG_CPLUSPLUS
+ OLD_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="-I/usr/include/musepack $CPPFLAGS"
+ AC_CHECK_HEADER(mpc_dec.h, [
+ HAVE_MUSEPACK="yes"
+ MUSEPACK_LIBS="-lmusepack"
+ MUSEPACK_CFLAGS="-I/usr/include/musepack"
+ AC_SUBST(MUSEPACK_CFLAGS)
+ AC_SUBST(MUSEPACK_LIBS)
+ ], [HAVE_MUSEPACK="no"])
+ CPPFLAGS="$OLD_CPPFLAGS"
+ AC_LANG_C
+])
+
dnl *** musicbrainz ***
dnl libmusicbrainz <= 2.0.2 has symbol clashes with ffmpeg
dnl however, our ffmpeg patch was accepted upstream
@@ -1948,6 +1965,7 @@ ext/mikmod/Makefile
ext/mpeg2dec/Makefile
ext/mpeg2enc/Makefile
ext/mplex/Makefile
+ext/musepack/Makefile
ext/musicbrainz/Makefile
ext/nas/Makefile
ext/ogg/Makefile