summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichal Benes <michal.benes@itonis.tv>2007-03-25 13:06:26 +0000
committerTim-Philipp Müller <tim@centricular.net>2007-03-25 13:06:26 +0000
commit8d5738ab90da66e297b5611c24faae96352257dd (patch)
treef2cec796d6ec6f556af4dfbc26070ef6c7b3784e /configure.ac
parentd0b8c40cec16ecef4b270d39c3e88bf4d0d3cda3 (diff)
downloadgst-plugins-bad-8d5738ab90da66e297b5611c24faae96352257dd.tar.gz
gst-plugins-bad-8d5738ab90da66e297b5611c24faae96352257dd.tar.bz2
gst-plugins-bad-8d5738ab90da66e297b5611c24faae96352257dd.zip
Add libx264-based h264 encoder plugin (#421110). Probably doesn't handle 'odd' widths and heights correctly yet.
Original commit message from CVS: Patch by: Michal Benes <michal.benes at itonis tv> Patch by: Josef Zlomek <josef.zlomek at itonis tv> * configure.ac: * ext/Makefile.am: * ext/x264/Makefile.am: * ext/x264/gstx264enc.c: (gst_x264_enc_me_get_type), (gst_x264_enc_analyse_get_type), (gst_x264_enc_timestamp_queue_init), (gst_x264_enc_timestamp_queue_free), (gst_x264_enc_timestamp_queue_put), (gst_x264_enc_timestamp_queue_get), (gst_x264_enc_header_buf), (gst_x264_enc_set_src_caps), (gst_x264_enc_sink_set_caps), (gst_x264_enc_base_init), (gst_x264_enc_class_init), (gst_x264_enc_init), (gst_x264_enc_init_encoder), (gst_x264_enc_close_encoder), (gst_x264_enc_dispose), (gst_x264_enc_sink_event), (gst_x264_enc_chain), (gst_x264_enc_encode_frame), (gst_x264_enc_change_state), (gst_x264_enc_set_property), (gst_x264_enc_get_property), (plugin_init): * ext/x264/gstx264enc.h: Add libx264-based h264 encoder plugin (#421110). Probably doesn't handle 'odd' widths and heights correctly yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fa31a459..c60291fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -903,6 +903,16 @@ AG_GST_CHECK_FEATURE(THEORADEC, [ogg theora codec], theoraexpdec, [
AC_SUBST(THEORADEC_CFLAGS)
])
+dnl *** x264 (MPEG-4 part 10/h.264/AVC encoder) ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_X264, true)
+AG_GST_CHECK_FEATURE(X264, [x264 plug-in], x264, [
+ AG_GST_CHECK_LIBHEADER(X264, x264, x264_nal_encode, -lm, x264.h,
+ X264_LIBS="$LDFLAGS -lx264 -lm"
+ X264_CFLAGS="$CFLAGS"
+ AC_SUBST(X264_LIBS)
+ AC_SUBST(X264_CFLAGS))
+])
+
dnl *** XVID ***
translit(dnm, m, l) AM_CONDITIONAL(USE_XVID, true)
AG_GST_CHECK_FEATURE(XVID, [xvid plugins], xvid, [
@@ -995,6 +1005,7 @@ AM_CONDITIONAL(USE_SOUNDTOUCH, false)
AM_CONDITIONAL(USE_SPC, false)
AM_CONDITIONAL(USE_SWFDEC, false)
AM_CONDITIONAL(USE_THEORADEC, false)
+AM_CONDITIONAL(USE_X264, false)
AM_CONDITIONAL(USE_XVID, false)
AM_CONDITIONAL(USE_WAVPACK, false)
AM_CONDITIONAL(USE_DVB, false)
@@ -1121,6 +1132,7 @@ ext/swfdec/Makefile
ext/theora/Makefile
ext/timidity/Makefile
ext/wavpack/Makefile
+ext/x264/Makefile
ext/xvid/Makefile
po/Makefile.in
docs/Makefile