summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2006-07-18 14:08:06 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-07-18 14:08:06 +0000
commit8dd45c0027604b6ff82807760da7a77da4e1b4b6 (patch)
treeb2d863cff7cbeb7ecfc5c4fc5fbb4280a347ea2c /configure.ac
parent4071cd900f58791470a1f569122297190ca0b790 (diff)
downloadgst-plugins-bad-8dd45c0027604b6ff82807760da7a77da4e1b4b6.tar.gz
gst-plugins-bad-8dd45c0027604b6ff82807760da7a77da4e1b4b6.tar.bz2
gst-plugins-bad-8dd45c0027604b6ff82807760da7a77da4e1b4b6.zip
configure.ac: Check for wavpack version and define WAVPACK_OLD_API if necessary.
Original commit message from CVS: Patch by: Sebastian Dröge <slomo at circular-chaos.org> * configure.ac: Check for wavpack version and define WAVPACK_OLD_API if necessary. * ext/wavpack/Makefile.am: * ext/wavpack/gstwavpackcommon.c: (gst_wavpack_read_header), (gst_wavpack_read_metadata): * ext/wavpack/gstwavpackcommon.h: * ext/wavpack/gstwavpackdec.c: (gst_wavpack_dec_base_init), (gst_wavpack_dec_class_init), (gst_wavpack_dec_init), (gst_wavpack_dec_finalize), (gst_wavpack_dec_format_samples), (gst_wavpack_dec_clip_outgoing_buffer), (gst_wavpack_dec_chain), (gst_wavpack_dec_sink_event), (gst_wavpack_dec_change_state), (gst_wavpack_dec_request_new_pad), (gst_wavpack_dec_plugin_init): * ext/wavpack/gstwavpackdec.h: * ext/wavpack/gstwavpackenc.c: (gst_wavpack_enc_class_init), (gst_wavpack_enc_init), (gst_wavpack_enc_finalize), (gst_wavpack_enc_set_wp_config): * ext/wavpack/gstwavpackparse.c: (gst_wavpack_parse_base_init), (gst_wavpack_parse_finalize), (gst_wavpack_parse_class_init), (gst_wavpack_parse_index_get_entry_from_sample), (gst_wavpack_parse_scan_to_find_sample), (gst_wavpack_parse_handle_seek_event), (gst_wavpack_parse_create_src_pad): * ext/wavpack/gstwavpackstreamreader.c: * ext/wavpack/gstwavpackstreamreader.h: Port to new/official wavpack API, don't use API that was exported in wavpack header files and in the lib but meant to be private, at least not for recent wavpack versions; misc. 'cleanups' (#347443).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ce0660b2..33aa690e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -728,9 +728,14 @@ int main () { return 0; }
dnl *** wavpack ***
translit(dnm, m, l) AM_CONDITIONAL(USE_WAVPACK, true)
GST_CHECK_FEATURE(WAVPACK, [wavpack plug-in], wavpack, [
- PKG_CHECK_MODULES(WAVPACK, wavpack >= 4.2, HAVE_WAVPACK=yes, [
- HAVE_WAVPACK=no
- AC_MSG_RESULT(no)
+ PKG_CHECK_MODULES(WAVPACK, wavpack >= 4.33, HAVE_WAVPACK=yes, [
+ PKG_CHECK_MODULES(WAVPACK, wavpack >= 4.20, [
+ HAVE_WAVPACK=yes
+ AC_DEFINE(WAVPACK_OLD_API, 1, [old wavpack API])
+ ],[
+ HAVE_WAVPACK=no
+ AC_MSG_RESULT(no)
+ ])
])
AC_SUBST(WAVPACK_CFLAGS)
AC_SUBST(WAVPACK_LIBS)