summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Schaller <uraeus@gnome.org>2005-05-05 16:35:52 +0000
committerChristian Schaller <uraeus@gnome.org>2005-05-05 16:35:52 +0000
commit90c2020e84bf5da095b6608c66fee8c8fe6f6426 (patch)
tree942c6d436f9ba70747cbc2063a2d87a246852154 /configure.ac
parent94bc644f6c1d3cf4564078fc92d30212683852e1 (diff)
downloadgst-plugins-bad-90c2020e84bf5da095b6608c66fee8c8fe6f6426.tar.gz
gst-plugins-bad-90c2020e84bf5da095b6608c66fee8c8fe6f6426.tar.bz2
gst-plugins-bad-90c2020e84bf5da095b6608c66fee8c8fe6f6426.zip
updates to make this closer to compile
Original commit message from CVS: updates to make this closer to compile
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4ba8daa..dd9e4f0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -223,6 +223,27 @@ fi
AC_SUBST(GST_CONTROL_LIBS)
+dnl check for gstreamer-base; uninstalled is selected preferentially
+PKG_CHECK_MODULES(GST_BASE, gstreamer-base-$GST_MAJORMINOR >= $GST_REQ,
+ HAVE_GST_BASE="yes", HAVE_GST_BASE="no")
+
+if test "x$HAVE_GST_BASE" = "xno"; then
+ AC_MSG_ERROR(no GStreamer Base Libs found)
+fi
+
+AC_SUBST(GST_BASE_LIBS)
+
+dnl check for gstreamer-interfaces; uinstalled is selected preferentially
+PKG_CHECK_MODULES(GST_INTERFACES, gstreamer-interfaces-$GST_MAJORMINOR >= $GST_REQ,
+ HAVE_GST_INTERFACES="yes", HAVE_GST_INTERFACES="no")
+
+if test "x$HAVE_GST_INTERFACES" = "xno"; then
+ AC_MSG_ERROR(no GStreamer Interfaces Libs found)
+fi
+
+AC_SUBST(GST_INTERFACES_LIBS)
+
+
dnl Determine endianness
AC_C_BIGENDIAN