summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2007-11-01 16:04:29 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2007-11-01 16:04:29 +0000
commit929954f595220293179b7ce22f563f1707934566 (patch)
tree786173419229d5f8f8bbbb28dd201a27d75baeeb /configure.ac
parent5888898c570f0f22c930d8c66fe0949d00a90b93 (diff)
downloadgst-plugins-bad-929954f595220293179b7ce22f563f1707934566.tar.gz
gst-plugins-bad-929954f595220293179b7ce22f563f1707934566.tar.bz2
gst-plugins-bad-929954f595220293179b7ce22f563f1707934566.zip
Some XMP stuff added.
Original commit message from CVS: Some XMP stuff added.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7231a8cf..fb6334e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -496,7 +496,15 @@ AG_GST_CHECK_FEATURE(METADATA, [METADATA muxer and demuxer], metadata, [
PKG_CHECK_MODULES(IPTC, libiptcdata >= 1.0.2, HAVE_IPTC="yes", [
HAVE_IPTC="no"
])
- HAVE_XMP="no"
+ AC_CHECK_HEADER(exempi-2.0/exempi/xmp.h,
+ [
+ AC_CHECK_LIB(exempi, xmp_init,
+ [
+ HAVE_XMP="yes"
+ XMP_CFLAGS="-I/usr/local/include/exempi-2.0/exempi/"
+ XMP_LIBS="-lexempi"
+ ], HAVE_XMP="no")
+ ], HAVE_XMP="no")
if test x$HAVE_EXIF = xyes; then
METADATA_CFLAGS="-DHAVE_EXIF $EXIF_CFLAGS $METADATA_CFLAGS"
METADATA_LIBS="$EXIF_LIBS $METADATA_LIBS"
@@ -513,8 +521,10 @@ AG_GST_CHECK_FEATURE(METADATA, [METADATA muxer and demuxer], metadata, [
HAVE_METADATA="yes"
fi
if test x$HAVE_METADATA = xno; then
- AC_MSG_RESULT(no)
+ AC_MSG_WARN(no of metadata libraries (exif, iptc or xmp) found)
fi
+ dnl metadata plugin will parse whole chunks anyway
+ HAVE_METADATA="yes"
AC_SUBST(METADATA_CFLAGS)
AC_SUBST(METADATA_LIBS)
])