summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@noraisin.net>2009-02-22 19:17:30 +0000
committerJan Schmidt <thaytan@noraisin.net>2009-02-22 19:18:36 +0000
commit98dccb65bf1d188eb4bf32821188dbb00678c3e1 (patch)
tree0d98e809f684780dbe8a1b5c3dd0bac36815bf88 /configure.ac
parent731bf5d26e449d90000346d6da17f5bc0cf065fb (diff)
downloadgst-plugins-bad-98dccb65bf1d188eb4bf32821188dbb00678c3e1.tar.gz
gst-plugins-bad-98dccb65bf1d188eb4bf32821188dbb00678c3e1.tar.bz2
gst-plugins-bad-98dccb65bf1d188eb4bf32821188dbb00678c3e1.zip
Detect libsoundtouch 1.4 and higher.
In libsoundtouch 1.4, libBPM appears to have been subsumed into libSoundTouch, and into the soundtouch namespace.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31cb9b78..31b5c514 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1172,6 +1172,11 @@ AG_GST_CHECK_FEATURE(SOUNDTOUCH, [soundtouch plug-in], soundtouch, [
[PKG_CHECK_MODULES(SOUNDTOUCH, libSoundTouch,
HAVE_SOUNDTOUCH=yes,
HAVE_SOUNDTOUCH=no)])
+ dnl We only need -lBPM on soundtouch < 1.4
+ PKG_CHECK_EXISTS(libSoundTouch >= 1.4,
+ AC_DEFINE([HAVE_SOUNDTOUCH_1_4], [1],
+ [Defined if the available libSoundTouch is >= 1.4]),
+ SOUNDTOUCH_CFLAGS="$SOUNDTOUCH_CFLAGS -lBPM")
AC_SUBST(SOUNDTOUCH_CFLAGS)
AC_SUBST(SOUNDTOUCH_LIBS)
if test "x$HAVE_CXX" != "xyes"; then