summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2008-10-30 15:31:59 +0000
committerTim-Philipp Müller <tim@centricular.net>2008-10-30 15:31:59 +0000
commitaa67ed1d1478b118e57b85e465c3753608847866 (patch)
tree1e971cd4203143441188a8d07ef537be592ea51e /configure.ac
parent8d54b879f981efd05142e36f29a4558ee83342f1 (diff)
downloadgst-plugins-bad-aa67ed1d1478b118e57b85e465c3753608847866.tar.gz
gst-plugins-bad-aa67ed1d1478b118e57b85e465c3753608847866.tar.bz2
gst-plugins-bad-aa67ed1d1478b118e57b85e465c3753608847866.zip
configure.ac: Require at least Gtk 2.8.0 for the demos (that's the oldest I can test with; I'm fairly certain Gtk 2.0...
Original commit message from CVS: * configure.ac: Require at least Gtk 2.8.0 for the demos (that's the oldest I can test with; I'm fairly certain Gtk 2.0.0 is not good enough any longer); clean up some unused Gtk-related configure cruft. * examples/scaletempo/demo-gui.c: Define Gtk 2.12 function to noop when compiling against older Gtk.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 1 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index e644d5fd..7c983ad9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,27 +190,7 @@ AC_SUBST(GSTPB_PREFIX)
dnl GTK is optional and used in examples
HAVE_GTK=NO
-PKG_CHECK_MODULES(GTK2, gtk+-2.0 >= 2.2.0, HAVE_GTK_22=yes, HAVE_GTK_22=no)
-if test "x$HAVE_GTK_22" = "xyes"; then
- HAVE_GTK=yes
- GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-2.0`
- AC_SUBST(GTK_VERSION)
- GTK_PREFIX=`$PKG_CONFIG --variable=prefix gdk-pixbuf-2.0`
- AC_SUBST(GTK_BASE_DIR)
- GDK_PIXBUF_LIBDIR=`$PKG_CONFIG --variable=libdir gdk-pixbuf-2.0`
- GDK_PIXBUF_PREFIXDIR=`$PKG_CONFIG --variable=prefix gdk-pixbuf-2.0`
- AC_SUBST(GTK_BASE_DIR)
-else
- PKG_CHECK_MODULES(GTK2, gtk+-2.0, HAVE_GTK_20=yes, HAVE_GTK_20=no)
-fi
-if test "x$HAVE_GTK_20" = "xyes"; then
- HAVE_GTK=yes
-fi
-GTK_CFLAGS=$GTK2_CFLAGS
-GTK_LIBS=$GTK2_LIBS
-AC_SUBST(GTK_LIBS)
-AC_SUBST(GTK_CFLAGS)
-AC_SUBST(HAVE_GTK)
+PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.8.0, HAVE_GTK=yes, HAVE_GTK=no)
AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
dnl libglade is optional and only used in examples