summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2005-11-25 19:58:19 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2005-11-25 19:58:19 +0000
commitb066913324c8e5923dc036e5eefb02e5965f8790 (patch)
tree0af650a82c8a85983e0257199dc81a9c8eb7110b /configure.ac
parent584acf39528aa7faac911cee528b6f09d9d2855c (diff)
downloadgst-plugins-bad-b066913324c8e5923dc036e5eefb02e5965f8790.tar.gz
gst-plugins-bad-b066913324c8e5923dc036e5eefb02e5965f8790.tar.bz2
gst-plugins-bad-b066913324c8e5923dc036e5eefb02e5965f8790.zip
Wavpack ported to 0.9. No support for correction file yet.
Original commit message from CVS: Wavpack ported to 0.9. No support for correction file yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index dc922ece..ce1fcea5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -418,6 +418,15 @@ GST_CHECK_FEATURE(SDL, [SDL plug-in], sdlvideosink, [
AM_PATH_SDL(, HAVE_SDL=yes, HAVE_SDL=no)
])
+dnl *** wavpack ***
+dnl We ship our own version of the library
+translit(dnm, m, l) AM_CONDITIONAL(USE_WAVPACK, true)
+GST_CHECK_FEATURE(WAVPACK, [wavpack plug-in], wavpack, [
+ PKG_CHECK_MODULES(WAVPACK, wavpack >= 4.2, HAVE_WAVPACK=yes, HAVE_WAVPACK=no)
+ AC_SUBST(WAVPACK_CFLAGS)
+ AC_SUBST(WAVPACK_LIBS)
+])
+
dnl *** ivorbis ***
dnl AM_PATH_IVORBIS only takes two options
translit(dnm, m, l) AM_CONDITIONAL(USE_IVORBIS, true)
@@ -518,6 +527,7 @@ ext/Makefile
ext/directfb/Makefile
ext/faac/Makefile
ext/faad/Makefile
+ext/wavpack/Makefile
ext/ivorbis/Makefile
ext/gsm/Makefile
ext/musepack/Makefile