summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2008-03-06 03:16:13 +0000
committerDavid Schleef <ds@schleef.org>2008-03-06 03:16:13 +0000
commitb387715461ec1eab84eb2eb990e1a5562b9d8b42 (patch)
treee82c911268f803028e289187c857775b5e4fb3fd /configure.ac
parentacb81c58c547b0e6155fd61b7914f39deea428ad (diff)
downloadgst-plugins-bad-b387715461ec1eab84eb2eb990e1a5562b9d8b42.tar.gz
gst-plugins-bad-b387715461ec1eab84eb2eb990e1a5562b9d8b42.tar.bz2
gst-plugins-bad-b387715461ec1eab84eb2eb990e1a5562b9d8b42.zip
Rewrite Dirac encoder plugin based on Schroedinger gstreamer elements.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/dirac/Makefile.am: * ext/dirac/gstdirac.cc: * ext/dirac/gstdiracenc.cc: Rewrite Dirac encoder plugin based on Schroedinger gstreamer elements.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7ac6895..66e6e1b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -373,6 +373,15 @@ AG_GST_CHECK_FEATURE(DIRECTFB, [directfb], dfbvideosink , [
])
])
+dnl **** Dirac ****
+translit(dnm, m, l) AM_CONDITIONAL(USE_DIRAC, true)
+AG_GST_CHECK_FEATURE(DIRAC, [dirac], dirac, [
+ PKG_CHECK_MODULES(DIRAC, dirac >= 0.9, HAVE_DIRAC="yes", [
+ HAVE_DIRAC="no"
+ AC_MSG_RESULT(no)
+ ])
+])
+
dnl *** DTS ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DTS, true)
AG_GST_CHECK_FEATURE(DTS, [dts library], dtsdec, [
@@ -1156,6 +1165,7 @@ ext/alsaspdif/Makefile
ext/bz2/Makefile
ext/cdaudio/Makefile
ext/dc1394/Makefile
+ext/dirac/Makefile
ext/directfb/Makefile
ext/divx/Makefile
ext/dts/Makefile