summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2003-12-03 12:23:37 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2003-12-03 12:23:37 +0000
commitd83f9a59f27500690a25699bbe1b701f405e5ff3 (patch)
treef7d9bf8e9a7f2200964fdfc5ed6b6eab168ac8f5 /configure.ac
parent971f3208d44ec3084d6dd76bed32a817badabbba (diff)
downloadgst-plugins-bad-d83f9a59f27500690a25699bbe1b701f405e5ff3.tar.gz
gst-plugins-bad-d83f9a59f27500690a25699bbe1b701f405e5ff3.tar.bz2
gst-plugins-bad-d83f9a59f27500690a25699bbe1b701f405e5ff3.zip
fixing up X test and general features test
Original commit message from CVS: fixing up X test and general features test
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 21 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 02a8cbc1..8563f09f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -489,23 +489,27 @@ dnl ;;
])
dnl Check for X11
-AC_PATH_XTRA
-if test "-DX_DISPLAY_MISSING" = "$X_CFLAGS"; then
- AC_MSG_NOTICE([cannot find X11, the build system needs fixage])
- HAVE_X="no"
-else
- dnl this is much more than we want
- X_LIBS="$X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS"
- dnl AC_PATH_XTRA only defines the path needed to find the X libs, not the libs
- dnl therefore we add them here
- X_LIBS="$X_LIBS -lX11"
- AC_SUBST(X_CFLAGS)
- AC_SUBST(X_LIBS)
- HAVE_X="yes";
-fi
-AC_SUBST(HAVE_X)
-AM_CONDITIONAL(USE_X, test "-DX_DISPLAY_MISSING" != "$X_CFLAGS")
-
+translit(dnm, m, l) AM_CONDITIONAL(USE_X, true)
+GST_CHECK_FEATURE(X, [X libraries and plugins],
+ [ximagesink], [
+ AC_PATH_XTRA
+ if test "x$X_CFLAGS" == "x" -o "$X_CFLAGS" == "-DX_DISPLAY_MISSING"
+ then
+ AC_MSG_NOTICE([cannot find X11 development files])
+ HAVE_X="no"
+ else
+ dnl this is much more than we want
+ X_LIBS="$X_LIBS $X_PRE_LIBS $X_EXTRA_LIBS"
+ dnl AC_PATH_XTRA only defines the path needed to find the X libs, not the libs
+ dnl therefore we add them here
+ X_LIBS="$X_LIBS -lX11"
+ AC_SUBST(X_CFLAGS)
+ AC_SUBST(X_LIBS)
+ HAVE_X="yes"
+ fi
+ AC_SUBST(HAVE_X)
+])
+
dnl *** XVideo ***
dnl Look for the PIC library first, Debian requires it.
dnl Check debian-devel archives for gory details.