summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2009-02-24 16:21:18 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-02-24 16:21:18 +0100
commitda040c2a3529801e9b7c239afb698379ede89087 (patch)
tree6eba84b0c97ad713678b5810eefd5facc2038c81 /configure.ac
parentab1c576ec27f72644da0d69f69cb09dbf79413a7 (diff)
downloadgst-plugins-bad-da040c2a3529801e9b7c239afb698379ede89087.tar.gz
gst-plugins-bad-da040c2a3529801e9b7c239afb698379ede89087.tar.bz2
gst-plugins-bad-da040c2a3529801e9b7c239afb698379ede89087.zip
dtsdec: Use new DCA functions/constants as not all distros package the compat dts.h
For backward compatibility we define the DCA functions/constants to the old DTS functions/constants if we're building against libdts.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 42bbe84b..b0ddf9cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -572,11 +572,13 @@ dnl *** DTS ***
translit(dnm, m, l) AM_CONDITIONAL(USE_DTS, true)
AG_GST_CHECK_FEATURE(DTS, [dts library], dtsdec, [
HAVE_DTS="yes"
- AG_GST_CHECK_LIBHEADER(DTS, dca, dca_init, -lm, dts.h,
+ AG_GST_CHECK_LIBHEADER(DTS, dca, dca_init, -lm, dca.h,
DTS_LIBS="-ldca -lm", HAVE_DTS="no")
if test $HAVE_DTS = "no"; then
AG_GST_CHECK_LIBHEADER(DTS, dts_pic, dts_init, -lm, dts.h,
- DTS_LIBS="-ldts_pic -lm")
+ [ DTS_LIBS="-ldts_pic -lm"
+ AC_DEFINE(DTS_OLD, 1, [Define if an old libdts is used])
+ ])
fi
AC_SUBST(DTS_LIBS)
])