summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2007-06-08 17:36:46 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2007-06-08 17:36:46 +0000
commitdbf7acdf1d2218ba986021a3d6439cf848fd9162 (patch)
tree386e9afa04063b7efe64626e06c939ae9a03b7bb /configure.ac
parent0f7d9f156a06d0226b1a2b3b70e2786b9bf71e2b (diff)
downloadgst-plugins-bad-dbf7acdf1d2218ba986021a3d6439cf848fd9162.tar.gz
gst-plugins-bad-dbf7acdf1d2218ba986021a3d6439cf848fd9162.tar.bz2
gst-plugins-bad-dbf7acdf1d2218ba986021a3d6439cf848fd9162.zip
Remove DirectDraw & DirectSound plugins, as they've moved to Good
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-bad-plugins-docs.sgml: * docs/plugins/gst-plugins-bad-plugins-sections.txt: * docs/plugins/gst-plugins-bad-plugins.args: * docs/plugins/inspect/plugin-directdraw.xml: * docs/plugins/inspect/plugin-directsound.xml: * sys/Makefile.am: * sys/directdraw/Makefile.am: * sys/directdraw/gstdirectdrawplugin.c: * sys/directdraw/gstdirectdrawsink.c: * sys/directdraw/gstdirectdrawsink.h: * sys/directsound/Makefile.am: * sys/directsound/gstdirectsoundplugin.c: * sys/directsound/gstdirectsoundsink.c: * sys/directsound/gstdirectsoundsink.h: * win32/MANIFEST: * win32/gst.sln: * win32/vs6/libgstdirectdraw.dsp: * win32/vs6/libgstdirectsound.dsp: * win32/vs7/libgstdirectdraw.vcproj: * win32/vs7/libgstdirectsound.vcproj: * win32/vs8/libgstdirectdraw.vcproj: * win32/vs8/libgstdirectsound.vcproj: Remove DirectDraw & DirectSound plugins, as they've moved to Good
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac85
1 files changed, 0 insertions, 85 deletions
diff --git a/configure.ac b/configure.ac
index 54fbbaec..4e9ae620 100644
--- a/configure.ac
+++ b/configure.ac
@@ -318,87 +318,6 @@ AG_GST_CHECK_FEATURE(X, [X libraries and plugins],
CPPFLAGS="$ac_cppflags_save"
])
-dnl DirectDraw
-translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTDRAW, true)
-AG_GST_CHECK_FEATURE(DIRECTDRAW, [DirectDraw plug-in], directdrawsink, [
- HAVE_DIRECTDRAW="no"
- save_CFLAGS="$CFLAGS"
- save_LDFLAGS="$LDFLAGS"
- save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $DIRECTDRAW_CFLAGS"
- LDFLAGS="$LDFLAGS $DIRECTDRAW_LDFLAGS"
- LIBS="$LIBS -lddraw -lgdi32"
- AC_MSG_CHECKING(for DirectDraw LDFLAGS)
- AC_LINK_IFELSE([
-#include <windows.h>
-#include <ddraw.h>
-
-int main ()
-{
- GetStockObject(0);
- DirectDrawCreate(NULL, NULL, NULL);
-
- return 0;
-}
-],
- [HAVE_DIRECTDRAW="yes"],
- [HAVE_DIRECTDRAW="no"])
- AC_MSG_RESULT($HAVE_DIRECTDRAW)
- CFLAGS=$save_CFLAGS
- LDFLAGS=$save_LDFLAGS
- LIBS=$save_LIBS
-
- if test "x$HAVE_DIRECTDRAW" = "xyes"; then
- dnl this is much more than we want
- DIRECTDRAW_LIBS="-lddraw -ldxguid -lgdi32"
- AC_SUBST(DIRECTDRAW_CFLAGS)
- AC_SUBST(DIRECTDRAW_LDFLAGS)
- AC_SUBST(DIRECTDRAW_LIBS)
- fi
- AC_SUBST(HAVE_DIRECTDRAW)
-])
-
-dnl DirectSound
-translit(dnm, m, l) AM_CONDITIONAL(USE_DIRECTSOUND, true)
-AG_GST_CHECK_FEATURE(DIRECTSOUND, [DirectSound plug-in], directsoundsink, [
- HAVE_DIRECTSOUND="no"
- save_CFLAGS="$CFLAGS"
- save_LDFLAGS="$LDFLAGS"
- save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $DIRECTSOUND_CFLAGS"
- LDFLAGS="$LDFLAGS $DIRECTSOUND_LDFLAGS"
- LIBS="$LIBS -ldsound -ldxerr9"
- AC_MSG_CHECKING(for DirectSound LDFLAGS)
- AC_LINK_IFELSE([
-#include <windows.h>
-#include <dxerr9.h>
-#include <dsound.h>
-
-int main ()
-{
- DXGetErrorString9 (0);
- DirectSoundCreate(NULL, NULL, NULL);
-
- return 0;
-}
-],
- [HAVE_DIRECTSOUND="yes"],
- [HAVE_DIRECTSOUND="no"])
- AC_MSG_RESULT($HAVE_DIRECTSOUND)
- CFLAGS=$save_CFLAGS
- LDFLAGS=$save_LDFLAGS
- LIBS=$save_LIBS
-
- if test "x$HAVE_DIRECTSOUND" = "xyes"; then
- dnl this is much more than we want
- DIRECTSOUND_LIBS="-ldsound -ldxerr9"
- AC_SUBST(DIRECTSOUND_CFLAGS)
- AC_SUBST(DIRECTSOUND_LDFLAGS)
- AC_SUBST(DIRECTSOUND_LIBS)
- fi
- AC_SUBST(HAVE_DIRECTSOUND)
-])
-
dnl *** OS X video ***
translit(dnm, m, l) AM_CONDITIONAL(USE_OSX_VIDEO, true)
HAVE_OSX_VIDEO="no"
@@ -1004,8 +923,6 @@ AM_CONDITIONAL(USE_ALSA, false)
AM_CONDITIONAL(USE_AMRWB, false)
AM_CONDITIONAL(USE_BZ2, false)
AM_CONDITIONAL(USE_CDAUDIO, false)
-AM_CONDITIONAL(USE_DIRECTDRAW, false)
-AM_CONDITIONAL(USE_DIRECTSOUND, false)
AM_CONDITIONAL(USE_DIRECTFB, false)
AM_CONDITIONAL(USE_DTS, false)
AM_CONDITIONAL(USE_DIVX, false)
@@ -1126,8 +1043,6 @@ gst-libs/gst/app/Makefile
sys/Makefile
sys/glsink/Makefile
sys/dvb/Makefile
-sys/directdraw/Makefile
-sys/directsound/Makefile
sys/osxvideo/Makefile
examples/Makefile
examples/app/Makefile