summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-09-09 17:56:10 +0000
committerMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-09-09 17:56:10 +0000
commite262a72516fe2e4e67e400a7d35058f19a71d0da (patch)
tree77fbed2b7a1752252585e3498231e183762b77ee /configure.ac
parent7359989bdb60c61d32802c00a7c4cdb4362f96aa (diff)
downloadgst-plugins-bad-e262a72516fe2e4e67e400a7d35058f19a71d0da.tar.gz
gst-plugins-bad-e262a72516fe2e4e67e400a7d35058f19a71d0da.tar.bz2
gst-plugins-bad-e262a72516fe2e4e67e400a7d35058f19a71d0da.zip
Add jp2k plugin. Fixes #550657.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/jp2k/Makefile.am: * ext/jp2k/gstjasperdec.c: (gst_jasper_dec_base_init), (gst_jasper_dec_class_init), (gst_jasper_dec_init), (gst_jasper_dec_reset), (gst_jasper_dec_sink_setcaps), (gst_jasper_dec_negotiate), (gst_jasper_dec_get_picture), (gst_jasper_dec_chain), (gst_jasper_dec_set_property), (gst_jasper_dec_get_property), (gst_jasper_dec_change_state), (plugin_init): * ext/jp2k/gstjasperdec.h: Add jp2k plugin. Fixes #550657.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8ec0f6ef..515bd925 100644
--- a/configure.ac
+++ b/configure.ac
@@ -799,6 +799,14 @@ AG_GST_CHECK_FEATURE(JACK, Jack, jack, [
AC_SUBST(JACK_LIBS)
])
+dnl *** jp2k ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_JP2K, true)
+AG_GST_CHECK_FEATURE(JP2K, [jp2k], jp2kdec, [
+ AG_GST_CHECK_LIBHEADER(JP2K, jasper, jas_stream_fopen, , jasper/jasper.h,
+ JP2K_LIBS="-ljasper")
+ AC_SUBST(JP2K_LIBS)
+])
+
dnl *** ladspa ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LADSPA, true)
AG_GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
@@ -1296,6 +1304,7 @@ AM_CONDITIONAL(USE_FBDEV, false)
AM_CONDITIONAL(USE_GSM, false)
AM_CONDITIONAL(USE_IVORBIS, false)
AM_CONDITIONAL(USE_JACK, false)
+AM_CONDITIONAL(USE_JP2K, false)
AM_CONDITIONAL(USE_LADSPA, false)
AM_CONDITIONAL(USE_LIBMMS, false)
AM_CONDITIONAL(USE_METADATA, false)
@@ -1463,6 +1472,7 @@ ext/faad/Makefile
ext/gsm/Makefile
ext/ivorbis/Makefile
ext/jack/Makefile
+ext/jp2k/Makefile
ext/ladspa/Makefile
ext/libmms/Makefile
ext/Makefile