summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2009-03-26 12:10:05 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-03-26 12:10:05 +0100
commiteaea85ed4a2f8e442b713b50d89d5df35322c746 (patch)
tree437f3a29b14dfd1d523660899e6c0b8b9fd17acf /configure.ac
parent81af2259c256ece5e576c1ff2ed375b5b00587fa (diff)
downloadgst-plugins-bad-eaea85ed4a2f8e442b713b50d89d5df35322c746.tar.gz
gst-plugins-bad-eaea85ed4a2f8e442b713b50d89d5df35322c746.tar.bz2
gst-plugins-bad-eaea85ed4a2f8e442b713b50d89d5df35322c746.zip
xdgmime: Use GIOs g_content_type_guess() if possible
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77eacfb2..64427808 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,6 +316,12 @@ dnl disable experimental plug-ins
#if test "x$BUILD_EXPERIMENTAL" != "xyes"; then
#fi
+# For xdgmime, to use g_content_type_guess()
+PKG_CHECK_MODULES(GIO, gio-2.0 >= 2.16, HAVE_GIO=yes, HAVE_GIO=no)
+AM_CONDITIONAL(HAVE_GIO, test "x$HAVE_GIO" = "xyes")
+AC_SUBST(GIO_CFLAGS)
+AC_SUBST(GIO_LIBS)
+
dnl disable gst plugins we might not be able to build on this
dnl platform: librfb (ugly but minimally invasive)
dnl FIXME: maybe move to sys, or make work with winsock2