summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-04-12 09:14:29 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-04-12 09:14:29 +0000
commitfa9f92b7da848fccaf36acca9249a658cbd51d09 (patch)
tree7e0e2920db4ec9232c83e97d9e8745dbde0decfb /configure.ac
parentf39449ebd2cd43aee7a669d440c0bb303863951a (diff)
downloadgst-plugins-bad-fa9f92b7da848fccaf36acca9249a658cbd51d09.tar.gz
gst-plugins-bad-fa9f92b7da848fccaf36acca9249a658cbd51d09.tar.bz2
gst-plugins-bad-fa9f92b7da848fccaf36acca9249a658cbd51d09.zip
make sure there is a test registry to work against
Original commit message from CVS: make sure there is a test registry to work against
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3971c0fc..de9c370e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -227,6 +227,12 @@ if test -z $GST_TOOLS_DIR; then
fi
AC_SUBST(GST_TOOLS_DIR)
+GST_LIB_DIR=`pkg-config --variable=libdir gstreamer-$GST_MAJORMINOR`
+if test -z $GST_LIB_DIR; then
+ AC_MSG_ERROR([no libdir defined in GStreamer pkg-config file; core upgrade needed.])
+fi
+AC_SUBST(GST_LIB_DIR)
+
dnl check for gstreamer-control; uninstalled is selected preferentially
PKG_CHECK_MODULES(GST_CONTROL, gstreamer-control-$GST_MAJORMINOR >= $GST_REQ,
HAVE_GST_CONTROL="yes", HAVE_GST_CONTROL="no")