summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2009-03-26 11:23:30 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-03-26 11:23:30 +0100
commitfe9e680169e3e04ca98cebdf41f771310591d329 (patch)
tree307a280016ffbbe0a530027ae86b2ec609f88202 /configure.ac
parent6f62242c5f6765285564f42dd79d72a23b86b6a3 (diff)
downloadgst-plugins-bad-fe9e680169e3e04ca98cebdf41f771310591d329.tar.gz
gst-plugins-bad-fe9e680169e3e04ca98cebdf41f771310591d329.tar.bz2
gst-plugins-bad-fe9e680169e3e04ca98cebdf41f771310591d329.zip
dccp: Disable the dccp plugin if no pthread support is available
Partially fixes bug #573595.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 245e3e87..8dcf9cc4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,13 @@ AC_CHECK_HEADERS([sys/time.h])
dnl used by ext/dts
AX_CREATE_STDINT_H
+AC_CHECK_HEADERS([pthread.h], HAVE_PTHREAD_H=yes)
+AM_CONDITIONAL(HAVE_PTHREAD_H, test "x$HAVE_PTHREAD_H" = "xyes")
+
+if test "x$HAVE_PTHREAD_H" != "xyes"; then
+ GST_PLUGINS_SELECTED=`echo $GST_PLUGINS_SELECTED | $SED -e s/dccp//`
+fi
+
dnl *** checks for types/defines ***
dnl Check for FIONREAD ioctl declaration
@@ -322,6 +329,10 @@ if test "x$HAVE_SYS_SOCKET_H" != "xyes"; then
AG_GST_DISABLE_PLUGIN(librfb)
fi
+if test "x$HAVE_PTHREAD_H" != "xyes"; then
+ AG_GST_DISABLE_PLUGIN(dccp)
+fi
+
dnl *** sys plug-ins ***
dnl check for QuickTime