summaryrefslogtreecommitdiffstats
path: root/docs/plugins/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2007-05-30 14:52:07 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-05-30 14:52:07 +0000
commit853bb7b5dd839babdbac74ca9abfd30412b5b974 (patch)
tree934bc2a84160eeae2aca094f0726763f00dfa723 /docs/plugins/Makefile.am
parent1f13109b20980f3b0cd9c409c922cd2329a830b7 (diff)
downloadgst-plugins-bad-853bb7b5dd839babdbac74ca9abfd30412b5b974.tar.gz
gst-plugins-bad-853bb7b5dd839babdbac74ca9abfd30412b5b974.tar.bz2
gst-plugins-bad-853bb7b5dd839babdbac74ca9abfd30412b5b974.zip
Added videosignal plugin with two plugins to analyse video frames.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-bad-plugins-docs.sgml: * docs/plugins/gst-plugins-bad-plugins-sections.txt: * docs/plugins/inspect/plugin-videosignal.xml: * gst/videosignal/Makefile.am: * gst/videosignal/gstvideoanalyse.c: (gst_video_analyse_set_caps), (gst_video_analyse_post_message), (gst_video_analyse_420), (gst_video_analyse_transform_ip), (gst_video_analyse_set_property), (gst_video_analyse_get_property), (gst_video_analyse_base_init), (gst_video_analyse_class_init), (gst_video_analyse_init), (gst_video_analyse_get_type): * gst/videosignal/gstvideoanalyse.h: * gst/videosignal/gstvideodetect.c: (gst_video_detect_set_caps), (gst_video_detect_post_message), (gst_video_detect_calc_brightness), (gst_video_detect_420), (gst_video_detect_transform_ip), (gst_video_detect_set_property), (gst_video_detect_get_property), (gst_video_detect_base_init), (gst_video_detect_class_init), (gst_video_detect_init), (gst_video_detect_get_type): * gst/videosignal/gstvideodetect.h: * gst/videosignal/gstvideosignal.c: (plugin_init): * gst/videosignal/gstvideosignal.h: Added videosignal plugin with two plugins to analyse video frames. Added videoanalyse to report about brightness and variance in video frames. Added videodetect to detect predefined patterns in a video signal.
Diffstat (limited to 'docs/plugins/Makefile.am')
-rw-r--r--docs/plugins/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/docs/plugins/Makefile.am b/docs/plugins/Makefile.am
index 80c71c1b..380ef772 100644
--- a/docs/plugins/Makefile.am
+++ b/docs/plugins/Makefile.am
@@ -111,7 +111,9 @@ EXTRA_HFILES = \
$(top_srcdir)/gst/rtpmanager/gstrtpptdemux.h \
$(top_srcdir)/gst/rtpmanager/gstrtpsession.h \
$(top_srcdir)/gst/rtpmanager/gstrtpssrcdemux.h \
- $(top_srcdir)/gst/videocrop/gstvideocrop.h
+ $(top_srcdir)/gst/videocrop/gstvideocrop.h \
+ $(top_srcdir)/gst/videosignal/gstvideoanalyse.h \
+ $(top_srcdir)/gst/videosignal/gstvideodetect.h
# Images to copy into HTML directory.
HTML_IMAGES =