summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sourceforge.net>2008-09-15 09:34:14 +0000
committerStefan Kost <ensonic@users.sourceforge.net>2008-09-15 09:34:14 +0000
commit7386f71683ae7c0ad3cc742a746b36603cbfe7b5 (patch)
tree2396e2e1c2ee0ab25cd812d3f658eba31624a2ab /examples/Makefile.am
parentc1647d0369a523469dbd5d75de30b6f61319b8f0 (diff)
downloadgst-plugins-bad-7386f71683ae7c0ad3cc742a746b36603cbfe7b5.tar.gz
gst-plugins-bad-7386f71683ae7c0ad3cc742a746b36603cbfe7b5.tar.bz2
gst-plugins-bad-7386f71683ae7c0ad3cc742a746b36603cbfe7b5.zip
examples/Makefile.am: Only built scaletempo example if we have gtk.
Original commit message from CVS: * examples/Makefile.am: Only built scaletempo example if we have gtk.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index e4b5c6e2..245f070d 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,3 +1,8 @@
+if HAVE_GTK
+GTK_EXAMPLES=scaletempo
+else
+GTK_EXAMPLES=
+endif
if USE_DIRECTFB
DIRECTFB_DIR=directfb
@@ -5,5 +10,5 @@ else
DIRECTFB_DIR=
endif
-SUBDIRS= $(DIRECTFB_DIR) app switch scaletempo
+SUBDIRS= $(DIRECTFB_DIR) $(GTK_EXAMPLES) app switch
DIST_SUBDIRS= directfb app switch scaletempo