summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorWouter Cloetens <wouter@mind.be>2007-11-15 17:26:25 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-11-15 17:26:25 +0000
commit03d8e595a047894cbfdb24105d701e3cb6a0551b (patch)
tree98c20604b1a1dd279f4592c2e5eb1b9039f694b5 /ext/Makefile.am
parent621a4e4792bbc0d5b3a338024a3ce6c4053177f3 (diff)
downloadgst-plugins-bad-03d8e595a047894cbfdb24105d701e3cb6a0551b.tar.gz
gst-plugins-bad-03d8e595a047894cbfdb24105d701e3cb6a0551b.tar.bz2
gst-plugins-bad-03d8e595a047894cbfdb24105d701e3cb6a0551b.zip
Added HTTP source based on libsoup. Fixes #497020.
Original commit message from CVS: Patch by: Wouter Cloetens <wouter at mind dot be> * configure.ac: * ext/Makefile.am: * ext/soup/Makefile.am: * ext/soup/gstsouphttpsrc.c: (_do_init), (gst_souphttp_src_base_init), (gst_souphttp_src_class_init), (gst_souphttp_src_init), (gst_souphttp_src_dispose), (gst_souphttp_src_set_property), (gst_souphttp_src_get_property), (gst_souphttp_src_create), (gst_souphttp_src_start), (gst_souphttp_src_stop), (gst_souphttp_src_unlock), (gst_souphttp_src_set_location), (soup_got_chunk), (soup_response), (soup_session_close), (plugin_init): * ext/soup/gstsouphttpsrc.h: Added HTTP source based on libsoup. Fixes #497020.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index a777e108..db2fe1bc 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -94,6 +94,12 @@ else
FAAD_DIR=
endif
+#if USE_G729
+#G729_DIR=g729
+#else
+G729_DIR=
+#endif
+
if USE_GIO
GIO_DIR=gio
else
@@ -190,6 +196,12 @@ else
NEON_DIR=
endif
+if USE_SOUP
+SOUP_DIR=soup
+else
+SOUP_DIR=
+endif
+
if USE_TIMIDITY
TIMIDITY_DIR=timidity
else
@@ -292,6 +304,7 @@ SUBDIRS=\
$(FAAD_DIR) \
$(GIO_DIR) \
$(GSM_DIR) \
+ $(G729_DIR) \
$(HERMES_DIR) \
$(IVORBIS_DIR) \
$(JACK_DIR) \
@@ -306,6 +319,7 @@ SUBDIRS=\
$(MYTHTV_DIR) \
$(NAS_DIR) \
$(NEON_DIR) \
+ $(SOUP_DIR) \
$(POLYP_DIR) \
$(SDL_DIR) \
$(SHOUT_DIR) \
@@ -345,6 +359,7 @@ DIST_SUBDIRS = \
mythtv \
nas \
neon \
+ soup \
sdl \
sndfile \
soundtouch \