summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-21 11:46:15 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-21 11:46:15 +0000
commit3383f7c142fda4fb85faa1dfd9ae200b8277207a (patch)
tree3cf2e1cbe2dfaa95f8e90253097f5580cf1eb7ba /ext/Makefile.am
parentcc33fd24dbcd64369f1b6ce297f6eca9c0117b9f (diff)
downloadgst-plugins-bad-3383f7c142fda4fb85faa1dfd9ae200b8277207a.tar.gz
gst-plugins-bad-3383f7c142fda4fb85faa1dfd9ae200b8277207a.tar.bz2
gst-plugins-bad-3383f7c142fda4fb85faa1dfd9ae200b8277207a.zip
fixed some GST_LIBS stuff added audiofile added gst-libs/audio building
Original commit message from CVS: fixed some GST_LIBS stuff added audiofile added gst-libs/audio building
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index c0ad3282..3d1dd792 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -1,3 +1,9 @@
+if USE_AUDIOFILE
+AUDIOFILE_DIR=audiofile
+else
+AUDIOFILE_DIR=
+endif
+
if USE_ESD
ESD_DIR=esd
else
@@ -29,6 +35,7 @@ VORBIS_DIR=
endif
-SUBDIRS=$(ESD_DIR) $(LAME_DIR) $(MAD_DIR) $(SDL_DIR) $(VORBIS_DIR)
+SUBDIRS=$(AUDIOFILE_DIR) $(ESD_DIR) $(LAME_DIR) $(MAD_DIR) \
+ $(SDL_DIR) $(VORBIS_DIR)
-DIST_SUBDIRS=esd lame mad sdl vorbis
+DIST_SUBDIRS=audiofile esd lame mad sdl vorbis