summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-08-02 17:39:13 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-08-02 17:39:13 +0000
commit81717e11be8210ab758989639c34824bdcf2a33a (patch)
treeb2ec3a097a1723f05567d45d6aa823491e6102d2 /ext/Makefile.am
parentf783ef73b7d56aa049717fc5fcaff8add912f550 (diff)
downloadgst-plugins-bad-81717e11be8210ab758989639c34824bdcf2a33a.tar.gz
gst-plugins-bad-81717e11be8210ab758989639c34824bdcf2a33a.tar.bz2
gst-plugins-bad-81717e11be8210ab758989639c34824bdcf2a33a.zip
Add TwoLAME MP2 encoding element, based on the LAME element.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/twolame/Makefile.am: * ext/twolame/gsttwolame.c: (gst_two_lame_mode_get_type), (gst_two_lame_padding_get_type), (gst_two_lame_emphasis_get_type), (gst_two_lame_release_memory), (gst_two_lame_finalize), (gst_two_lame_base_init), (gst_two_lame_class_init), (gst_two_lame_src_setcaps), (gst_two_lame_sink_setcaps), (gst_two_lame_init), (gst_two_lame_set_property), (gst_two_lame_get_property), (gst_two_lame_sink_event), (gst_two_lame_chain), (gst_two_lame_setup), (gst_two_lame_change_state), (gst_two_lame_get_default_settings), (plugin_init): * ext/twolame/gsttwolame.h: Add TwoLAME MP2 encoding element, based on the LAME element.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index fdb3c6d5..9283086c 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -222,6 +222,12 @@ TIMIDITY_DIR=
endif
endif
+if USE_TWOLAME
+TWOLAME_DIR=twolame
+else
+TWOLAME_DIR=
+endif
+
# if USE_POLYP
# POLYP_DIR=polyp
# else
@@ -347,6 +353,7 @@ SUBDIRS=\
$(TARKIN_DIR) \
$(THEORA_DIR) \
$(TIMIDITY_DIR) \
+ $(TWOLAME_DIR) \
$(X264_DIR) \
$(XINE_DIR) \
$(XVID_DIR)