summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-22 23:57:40 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-22 23:57:40 +0000
commit9181b321d00b93a65be04dacc2833336366afcf5 (patch)
treef935b1eba217e9983eb1df70e154a03d01d8e6b7 /ext/Makefile.am
parent6193def94553b6d3e7f39fa975737d43b033a365 (diff)
downloadgst-plugins-bad-9181b321d00b93a65be04dacc2833336366afcf5.tar.gz
gst-plugins-bad-9181b321d00b93a65be04dacc2833336366afcf5.tar.bz2
gst-plugins-bad-9181b321d00b93a65be04dacc2833336366afcf5.zip
changes to accomodate the standardization of installed libs some left over changes
Original commit message from CVS: changes to accomodate the standardization of installed libs some left over changes
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 3d1dd792..2b2aca01 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -1,3 +1,15 @@
+if USE_A52
+A52_DIR=a52
+else
+A52_DIR=
+endif
+
+if USE_AALIB
+AALIB_DIR=aalib
+else
+AALIB_DIR=
+endif
+
if USE_AUDIOFILE
AUDIOFILE_DIR=audiofile
else
@@ -35,7 +47,8 @@ VORBIS_DIR=
endif
-SUBDIRS=$(AUDIOFILE_DIR) $(ESD_DIR) $(LAME_DIR) $(MAD_DIR) \
+SUBDIRS=$(A52_DIR) $(AALIB_DIR) $(AUDIOFILE_DIR) $(ESD_DIR) \
+ $(LAME_DIR) $(MAD_DIR) \
$(SDL_DIR) $(VORBIS_DIR)
-DIST_SUBDIRS=audiofile esd lame mad sdl vorbis
+DIST_SUBDIRS=a52 aalib audiofile esd lame mad sdl vorbis