summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-21 21:54:27 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-21 21:54:27 +0000
commitab57fbcd544e5226cb57aef7d54370f58e8badf4 (patch)
treec6f10a198cf57b4279b82ecb41069f66fd13ee9e /ext/Makefile.am
parent7ca8563737c8a87cdd54bb2aefe8321354c5362e (diff)
downloadgst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.tar.gz
gst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.tar.bz2
gst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.zip
Adds divx/xvid encoders. divx encoder is based on divx4linux (commercial, closed-source)
Original commit message from CVS: Adds divx/xvid encoders. * divx encoder is based on divx4linux (commercial, closed-source) * xvid encoder is based on xvidcore (http://www.xvid.org/, GPL - Christian? ;) ) Both use a GstCaps that doesn't conform with what we currently use, I might fix that later on or so. For now, it doesn't matter, it's just a test. We're also missing corresponding decoders (ffmpeg can decoded this too, but that's not the point), these might come later too.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am21
1 files changed, 17 insertions, 4 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 752bfbc2..cc849f97 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -46,6 +46,12 @@ else
CDPARANOIA_DIR=
endif
+if USE_DIVX
+DIVX_DIR=divx
+else
+DIVX_DIR=
+endif
+
if USE_DVDREAD
DVDREAD_DIR=dvdread
else
@@ -244,6 +250,12 @@ else
VORBIS_DIR=
endif
+if USE_XVID
+XVID_DIR=xvid
+else
+XVID_DIR=
+endif
+
if USE_XMMS
XMMS_DIR=xmms
else
@@ -257,8 +269,8 @@ SNAPSHOT_DIR=
endif
SUBDIRS=$(A52DEC_DIR) $(AALIB_DIR) $(ALSA_DIR) \
- $(ARTS_DIR) $(ARTSC_DIR) $(AUDIOFILE_DIR) \
- $(AVIFILE_DIR) $(CDPARANOIA_DIR) \
+ $(ARTS_DIR) $(ARTSC_DIR) $(AUDIOFILE_DIR) \
+ $(AVIFILE_DIR) $(CDPARANOIA_DIR) $(DIVX_DIR) \
$(DVDREAD_DIR) $(DVDNAV_DIR) $(ESD_DIR) $(MAS_DIR) \
$(FFMPEG_DIR) $(FLAC_DIR) $(GNOMEVFS_DIR) $(GSM_DIR) \
$(HERMES_DIR) $(HTTP_DIR) $(JACK_DIR) $(JPEG_DIR) \
@@ -268,7 +280,7 @@ SUBDIRS=$(A52DEC_DIR) $(AALIB_DIR) $(ALSA_DIR) \
$(OPENQUICKTIME_DIR) $(RAW1394_DIR) \
$(SDL_DIR) $(SHOUT_DIR) $(SIDPLAY_DIR) \
$(SMOOTHWAVE_DIR) $(SWFDEC_DIR) $(TARKIN_DIR) \
- $(VORBIS_DIR) $(XMMS_DIR) $(SNAPSHOT_DIR)
+ $(VORBIS_DIR) $(XVID_DIR) $(XMMS_DIR) $(SNAPSHOT_DIR)
DIST_SUBDIRS=\
a52dec aalib alsa \
@@ -281,4 +293,5 @@ DIST_SUBDIRS=\
mad mikmod mjpegtools mpeg2dec \
openquicktime raw1394 \
sdl snapshot shout shout2 sidplay \
- smoothwave swfdec tarkin vorbis xmms
+ smoothwave swfdec tarkin vorbis \
+ xmms xvid