summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-21 09:41:40 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-21 09:41:40 +0000
commitc6d1ec9d5a710062e71a3462cf49899855acb52b (patch)
treef8fe27708b806213c9115bb7f0eb8faca6a14376 /ext/Makefile.am
parent88c12ec7a0bc09ce5a819e04fcbd87cfbe6955a4 (diff)
downloadgst-plugins-bad-c6d1ec9d5a710062e71a3462cf49899855acb52b.tar.gz
gst-plugins-bad-c6d1ec9d5a710062e71a3462cf49899855acb52b.tar.bz2
gst-plugins-bad-c6d1ec9d5a710062e71a3462cf49899855acb52b.zip
this one could come in handy
Original commit message from CVS: this one could come in handy
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
new file mode 100644
index 00000000..c0ad3282
--- /dev/null
+++ b/ext/Makefile.am
@@ -0,0 +1,34 @@
+if USE_ESD
+ESD_DIR=esd
+else
+ESD_DIR=
+endif
+
+if USE_LAME
+LAME_DIR=lame
+else
+LAME_DIR=
+endif
+
+if USE_MAD
+MAD_DIR=mad
+else
+MAD_DIR=
+endif
+
+if USE_SDL
+SDL_DIR=sdl
+else
+SDL_DIR=
+endif
+
+if USE_VORBIS
+VORBIS_DIR=vorbis
+else
+VORBIS_DIR=
+endif
+
+
+SUBDIRS=$(ESD_DIR) $(LAME_DIR) $(MAD_DIR) $(SDL_DIR) $(VORBIS_DIR)
+
+DIST_SUBDIRS=esd lame mad sdl vorbis