summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-09-09 17:56:10 +0000
committerMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-09-09 17:56:10 +0000
commite262a72516fe2e4e67e400a7d35058f19a71d0da (patch)
tree77fbed2b7a1752252585e3498231e183762b77ee /ext/Makefile.am
parent7359989bdb60c61d32802c00a7c4cdb4362f96aa (diff)
downloadgst-plugins-bad-e262a72516fe2e4e67e400a7d35058f19a71d0da.tar.gz
gst-plugins-bad-e262a72516fe2e4e67e400a7d35058f19a71d0da.tar.bz2
gst-plugins-bad-e262a72516fe2e4e67e400a7d35058f19a71d0da.zip
Add jp2k plugin. Fixes #550657.
Original commit message from CVS: * configure.ac: * ext/Makefile.am: * ext/jp2k/Makefile.am: * ext/jp2k/gstjasperdec.c: (gst_jasper_dec_base_init), (gst_jasper_dec_class_init), (gst_jasper_dec_init), (gst_jasper_dec_reset), (gst_jasper_dec_sink_setcaps), (gst_jasper_dec_negotiate), (gst_jasper_dec_get_picture), (gst_jasper_dec_chain), (gst_jasper_dec_set_property), (gst_jasper_dec_get_property), (gst_jasper_dec_change_state), (plugin_init): * ext/jp2k/gstjasperdec.h: Add jp2k plugin. Fixes #550657.
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index c27246a7..a3e6e918 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -130,6 +130,12 @@ else
JACK_DIR=
endif
+if USE_JP2K
+JP2K_DIR = jp2k
+else
+JP2K_DIR =
+endif
+
if USE_LADSPA
LADSPA_DIR = ladspa
else
@@ -329,6 +335,7 @@ SUBDIRS=\
$(HERMES_DIR) \
$(IVORBIS_DIR) \
$(JACK_DIR) \
+ $(JP2K_DIR) \
$(LADSPA_DIR) \
$(LCS_DIR) \
$(LIBFAME_DIR) \
@@ -374,6 +381,7 @@ DIST_SUBDIRS = \
ivorbis \
ladspa \
jack \
+ jp2k \
libmms \
dts \
divx \