summaryrefslogtreecommitdiffstats
path: root/ext/audioresample/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-12-16 05:32:07 +0000
committerDavid Schleef <ds@schleef.org>2004-12-16 05:32:07 +0000
commite803c9f86d25e07da2fb30212505018b6f2644b9 (patch)
treec3b539ec71a3a28b6d3fa001a17ad90bf1ce001c /ext/audioresample/Makefile.am
parent7de6c44f445f0bf72fb34f751c1ae333e7a8a661 (diff)
downloadgst-plugins-bad-e803c9f86d25e07da2fb30212505018b6f2644b9.tar.gz
gst-plugins-bad-e803c9f86d25e07da2fb30212505018b6f2644b9.tar.bz2
gst-plugins-bad-e803c9f86d25e07da2fb30212505018b6f2644b9.zip
configure.ac: add audioresample and cairo plugins. Remove
Original commit message from CVS: * configure.ac: add audioresample and cairo plugins. Remove HAVE_MMX stuff, because it's not used. * ext/Makefile.am: same * ext/audioresample/Makefile.am: You are not ready for an audio resampling element based on audioresample. * ext/audioresample/gstaudioresample.c: * ext/audioresample/gstaudioresample.h: * ext/cairo/Makefile.am: You are not ready for overlay elements based on cairo. Don't look too closely, these elements kinda suck right now. * ext/cairo/gstcairo.c: new * ext/cairo/gsttextoverlay.c: new * ext/cairo/gsttextoverlay.h: new * ext/cairo/gsttimeoverlay.c: new * ext/cairo/gsttimeoverlay.h: new * gst-libs/gst/media-info/media-info-priv.h: fix compile problem with compilers that don't support variadic macros.
Diffstat (limited to 'ext/audioresample/Makefile.am')
-rw-r--r--ext/audioresample/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ext/audioresample/Makefile.am b/ext/audioresample/Makefile.am
new file mode 100644
index 00000000..777ff3cf
--- /dev/null
+++ b/ext/audioresample/Makefile.am
@@ -0,0 +1,10 @@
+
+plugin_LTLIBRARIES = libgstaudioresample.la
+
+libgstaudioresample_la_SOURCES = gstaudioresample.c
+libgstaudioresample_la_CFLAGS = $(GST_CFLAGS) $(AUDIORESAMPLE_CFLAGS)
+libgstaudioresample_la_LIBADD = $(AUDIORESAMPLE_LIBS)
+libgstaudioresample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstaudioresample.h
+