summaryrefslogtreecommitdiffstats
path: root/ext/bz2/Makefile.am
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2009-04-04 17:51:34 +0100
committerDave Robillard <dave@drobilla.net>2009-05-03 12:03:14 -0400
commitbd2e13e188dbf20efb686a176402cda7368d3800 (patch)
tree0e2e882aedcecb7ff2d1901705e94bb4db397187 /ext/bz2/Makefile.am
parent85879ddade524be923975e4679cd675edfb3773a (diff)
downloadgst-plugins-bad-bd2e13e188dbf20efb686a176402cda7368d3800.tar.gz
gst-plugins-bad-bd2e13e188dbf20efb686a176402cda7368d3800.tar.bz2
gst-plugins-bad-bd2e13e188dbf20efb686a176402cda7368d3800.zip
bz2: fix some refcount mistakes and do some cleaning up
No need to unref buffers if pad_push returns something non-FLOW_OK. In fact, this will cause assertions or crashes. However, we do need to unref the input buffer whenever we don't pass it downstream. Also, a non-OK flow return is not an error, so don't post error messages on the bus - the pipeline may just be shutting down. Miscellaneous other clean-ups and crack removal. Plenty of work left for those who feel like it.
Diffstat (limited to 'ext/bz2/Makefile.am')
-rw-r--r--ext/bz2/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/ext/bz2/Makefile.am b/ext/bz2/Makefile.am
index 617fa12e..4cc2c856 100644
--- a/ext/bz2/Makefile.am
+++ b/ext/bz2/Makefile.am
@@ -3,7 +3,7 @@ plugin_LTLIBRARIES = libgstbz2.la
libgstbz2_la_SOURCES = \
gstbz2.c gstbz2dec.c gstbz2enc.c
-libgstbz2_la_CFLAGS = $(GST_BASE_CFLAGS)
+libgstbz2_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
libgstbz2_la_LIBADD = $(GST_BASE_LIBS) $(BZ2_LIBS)
libgstbz2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstbz2_la_LIBTOOLFLAGS = --tag=disable-static