summaryrefslogtreecommitdiffstats
path: root/ext/directfb/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2005-11-02 12:43:03 +0000
committerJulien Moutte <julien@moutte.net>2005-11-02 12:43:03 +0000
commitd99ae29b78d8087c426b6132f7c6292240581422 (patch)
tree2971a4f7db8614d7a4dab5b5dd4d3ce351d4632b /ext/directfb/Makefile.am
parent801be361c18372ec28732ef55212fbbfa9deaf9c (diff)
downloadgst-plugins-bad-d99ae29b78d8087c426b6132f7c6292240581422.tar.gz
gst-plugins-bad-d99ae29b78d8087c426b6132f7c6292240581422.tar.bz2
gst-plugins-bad-d99ae29b78d8087c426b6132f7c6292240581422.zip
Complete rewrite/port of
Original commit message from CVS: 2005-11-02 Julien MOUTTE <julien@moutte.net> * configure.ac: * ext/Makefile.am: * ext/directfb/Makefile.am: * ext/directfb/dfbvideosink.c: (gst_dfbvideosink_get_format_name), (gst_dfbvideosink_surface_create), (gst_dfbvideosink_surface_destroy), (gst_dfbvideosink_event_thread), (gst_dfbvideosink_enum_layers), (gst_dfbvideosink_enum_vmodes), (gst_dfbvideosink_enum_devices), (gst_dfbvideosink_setup), (gst_dfbvideosink_cleanup), (gst_dfbvideosink_get_format_from_caps), (gst_dfbvideosink_get_caps_from_format), (gst_dfbvideosink_can_blit_from_format), (gst_dfbvideosink_get_best_vmode), (gst_dfbvideosink_getcaps), (gst_dfbvideosink_setcaps), (gst_dfbvideosink_change_state), (gst_dfbvideosink_get_times), (gst_dfbvideosink_center_rect), (gst_dfbvideosink_show_frame), (gst_dfbvideosink_bufferpool_clear), (gst_dfbvideosink_buffer_alloc), (gst_dfbsurface_finalize), (gst_dfbsurface_init), (gst_dfbsurface_class_init), (gst_dfbsurface_get_type), (gst_dfbvideosink_interface_supported), (gst_dfbvideosink_interface_init), (gst_dfbvideosink_navigation_send_event), (gst_dfbvideosink_navigation_init), (gst_dfbvideosink_set_property), (gst_dfbvideosink_get_property), (gst_dfbvideosink_init), (gst_dfbvideosink_base_init), (gst_dfbvideosink_class_init), (gst_dfbvideosink_get_type), (plugin_init): * ext/directfb/dfbvideosink.h: * ext/directfb/directfbvideosink.c: * ext/directfb/directfbvideosink.h: Complete rewrite/port of DirectFB video sink to 0.9. Handles reverse negotiation, hardware scaling, navigation, buffer allocation from video memory etc...
Diffstat (limited to 'ext/directfb/Makefile.am')
-rw-r--r--ext/directfb/Makefile.am19
1 files changed, 10 insertions, 9 deletions
diff --git a/ext/directfb/Makefile.am b/ext/directfb/Makefile.am
index dd0aabdf..47f98984 100644
--- a/ext/directfb/Makefile.am
+++ b/ext/directfb/Makefile.am
@@ -1,13 +1,14 @@
plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
-plugin_LTLIBRARIES = libgstdirectfbvideosink.la
+plugin_LTLIBRARIES = libgstdfbvideosink.la
-libgstdirectfbvideosink_la_SOURCES = directfbvideosink.c
-libgstdirectfbvideosink_la_CFLAGS = $(GST_CFLAGS) \
- $(DIRECTFB_CFLAGS) \
- $(GST_OPT_CFLAGS)
-libgstdirectfbvideosink_la_LIBADD = $(DIRECTFB_LIBS) \
- $(top_builddir)/gst-libs/gst/libgstinterfaces-$(GST_MAJORMINOR).la
-libgstdirectfbvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstdfbvideosink_la_SOURCES = dfbvideosink.c
+libgstdfbvideosink_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
+ $(DIRECTFB_CFLAGS)
+libgstdfbvideosink_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
+ -lgstvideo-$(GST_MAJORMINOR) \
+ -lgstinterfaces-$(GST_MAJORMINOR) \
+ $(DIRECTFB_LIBS)
+libgstdfbvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = directfbvideosink.h
+noinst_HEADERS = dfbvideosink.h