summaryrefslogtreecommitdiffstats
path: root/ext/directfb/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2005-11-03 22:36:42 +0000
committerJulien Moutte <julien@moutte.net>2005-11-03 22:36:42 +0000
commitda12a5ed8d76f284555b5d4fa0ea76120b12dc43 (patch)
tree88683b73cfd3ae0384ad2343cdda69b2b9900f1a /ext/directfb/Makefile.am
parentabaa4ba211e9da97f200831a8b0f0a84251e154a (diff)
downloadgst-plugins-bad-da12a5ed8d76f284555b5d4fa0ea76120b12dc43.tar.gz
gst-plugins-bad-da12a5ed8d76f284555b5d4fa0ea76120b12dc43.tar.bz2
gst-plugins-bad-da12a5ed8d76f284555b5d4fa0ea76120b12dc43.zip
ext/directfb/Makefile.am: Prepare for liboil usage.
Original commit message from CVS: 2005-11-03 Julien MOUTTE <julien@moutte.net> * ext/directfb/Makefile.am: Prepare for liboil usage. * ext/directfb/dfbvideosink.c: (gst_dfbvideosink_show_frame), (gst_dfbvideosink_buffer_alloc): Prepare for liboil, handle rendering in external surface correctly. Will commit a neat example soon.
Diffstat (limited to 'ext/directfb/Makefile.am')
-rw-r--r--ext/directfb/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/ext/directfb/Makefile.am b/ext/directfb/Makefile.am
index 47f98984..eb90c28b 100644
--- a/ext/directfb/Makefile.am
+++ b/ext/directfb/Makefile.am
@@ -4,11 +4,11 @@ plugin_LTLIBRARIES = libgstdfbvideosink.la
libgstdfbvideosink_la_SOURCES = dfbvideosink.c
libgstdfbvideosink_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
- $(DIRECTFB_CFLAGS)
+ $(DIRECTFB_CFLAGS) $(LIBOIL_CFLAGS)
libgstdfbvideosink_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
- -lgstvideo-$(GST_MAJORMINOR) \
- -lgstinterfaces-$(GST_MAJORMINOR) \
- $(DIRECTFB_LIBS)
+ -lgstvideo-$(GST_MAJORMINOR) \
+ -lgstinterfaces-$(GST_MAJORMINOR) \
+ $(DIRECTFB_LIBS) $(LIBOIL_LIBS)
libgstdfbvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = dfbvideosink.h