summaryrefslogtreecommitdiffstats
path: root/ext/hermes/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2001-12-23 14:25:32 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2001-12-23 14:25:32 +0000
commit854a7e0af7f9e106ff389ba0b2d4361021639fea (patch)
tree1f3b6b538479e21f476cba64e38c32993dd7788b /ext/hermes/Makefile.am
parentb4b7683df9bf1f7cc85e239c175817740197dfe6 (diff)
downloadgst-plugins-bad-854a7e0af7f9e106ff389ba0b2d4361021639fea.tar.gz
gst-plugins-bad-854a7e0af7f9e106ff389ba0b2d4361021639fea.tar.bz2
gst-plugins-bad-854a7e0af7f9e106ff389ba0b2d4361021639fea.zip
adding hermes
Original commit message from CVS: adding hermes
Diffstat (limited to 'ext/hermes/Makefile.am')
-rw-r--r--ext/hermes/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ext/hermes/Makefile.am b/ext/hermes/Makefile.am
new file mode 100644
index 00000000..b7447e5e
--- /dev/null
+++ b/ext/hermes/Makefile.am
@@ -0,0 +1,17 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libgstcolorspace.la
+
+if HAVE_CPU_I386
+ARCHSRCS = yuv2rgb_mmx16.s
+else
+ARCHSRCS =
+endif
+
+libcolorspace_la_SOURCES = gstcolorspace.c yuv2yuv.c yuv2rgb.c $(ARCHSRCS)
+libcolorspace_la_CFLAGS = $(GST_CFLAGS)
+if HAVE_LIBHERMES
+libcolorspace_la_LIBADD = $(HERMES_LIBS)
+endif
+
+noinst_HEADERS = gstcolorspace.h yuv2rgb.h