summaryrefslogtreecommitdiffstats
path: root/ext/ladspa/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sf.net>2009-03-04 14:34:12 +0200
committerStefan Kost <ensonic@users.sf.net>2009-03-04 15:10:30 +0200
commit86c5975ebe15ccf8d16018271c90379ab62256ae (patch)
tree8284a6dcb87057e29d57caca22f6879caabe18e5 /ext/ladspa/Makefile.am
parentccaa8de5aad3e4abf7a6e015b4da07968223e569 (diff)
downloadgst-plugins-bad-86c5975ebe15ccf8d16018271c90379ab62256ae.tar.gz
gst-plugins-bad-86c5975ebe15ccf8d16018271c90379ab62256ae.tar.bz2
gst-plugins-bad-86c5975ebe15ccf8d16018271c90379ab62256ae.zip
ladspa: rewrite the directory scanning, fixes first part of #573370
Move the two function from search.c into gstladspa.c and make them static. Remove non needed arguments from function prototypes. Use glib api for simplicity and portability.
Diffstat (limited to 'ext/ladspa/Makefile.am')
-rw-r--r--ext/ladspa/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/ext/ladspa/Makefile.am b/ext/ladspa/Makefile.am
index c024d9da..ffd1e0ab 100644
--- a/ext/ladspa/Makefile.am
+++ b/ext/ladspa/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstladspa.la
-libgstladspa_la_SOURCES = gstsignalprocessor.c gstladspa.c search.c #load.c
+libgstladspa_la_SOURCES = gstsignalprocessor.c gstladspa.c
libgstladspa_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CONTROLLER_CFLAGS) $(GST_CFLAGS)
libgstladspa_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(LIBM) $(LADSPA_LIBS)
libgstladspa_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstladspa_la_LIBTOOLFLAGS = --tag=disable-static
-noinst_HEADERS = gstsignalprocessor.h gstladspa.h utils.h
+noinst_HEADERS = gstsignalprocessor.h gstladspa.h