summaryrefslogtreecommitdiffstats
path: root/ext/ladspa/Makefile.am
diff options
context:
space:
mode:
authorDave Robillard <dave@drobilla.net>2009-04-28 23:24:45 -0400
committerStefan Kost <ensonic@users.sf.net>2009-06-22 22:25:03 +0300
commitea184d72f532e4178221d7aa8881481f7f76798d (patch)
tree5e7a09e3172abcf609097e2e6d061f2f1a8ac652 /ext/ladspa/Makefile.am
parent1d464a7eddeb2a3b2f2d024a4ce121d288ea54db (diff)
downloadgst-plugins-bad-ea184d72f532e4178221d7aa8881481f7f76798d.tar.gz
gst-plugins-bad-ea184d72f532e4178221d7aa8881481f7f76798d.tar.bz2
gst-plugins-bad-ea184d72f532e4178221d7aa8881481f7f76798d.zip
Working LV2 plugin discovery.
- Separate gstsignalprocessor into a separate library (not sure if this is in the right place, but it works for now anyway) - Create LV2 element based on LADSPA element, port most discovery functionality
Diffstat (limited to 'ext/ladspa/Makefile.am')
-rw-r--r--ext/ladspa/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/ext/ladspa/Makefile.am b/ext/ladspa/Makefile.am
index 0ea92746..00582ed7 100644
--- a/ext/ladspa/Makefile.am
+++ b/ext/ladspa/Makefile.am
@@ -1,9 +1,9 @@
plugin_LTLIBRARIES = libgstladspa.la
-libgstladspa_la_SOURCES = gstsignalprocessor.c gstladspa.c
+libgstladspa_la_SOURCES = gstladspa.c
libgstladspa_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CONTROLLER_CFLAGS) $(GST_CFLAGS) $(LRDF_CFLAGS)
-libgstladspa_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(LIBM) $(LRDF_LIBS)
+libgstladspa_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) $(LIBM) $(LRDF_LIBS) ../../gst-libs/gst/signalprocessor/libgstsignalprocessor.la
libgstladspa_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstladspa_la_LIBTOOLFLAGS = --tag=disable-static
-noinst_HEADERS = gstsignalprocessor.h gstladspa.h
+noinst_HEADERS = gstladspa.h