summaryrefslogtreecommitdiffstats
path: root/ext/ofa/Makefile.am
diff options
context:
space:
mode:
authorEric Buehl <eric.buehl@gmail.com>2008-03-19 18:14:17 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-03-19 18:14:17 +0000
commitef2cb71d5fcad4dc3cbc239368a7bb9c30206761 (patch)
treefa5920a13c4b97898006780e1239196c0fe4bc94 /ext/ofa/Makefile.am
parent603b409c33ecc45e2e9b42e368ada98ff0c14d94 (diff)
downloadgst-plugins-bad-ef2cb71d5fcad4dc3cbc239368a7bb9c30206761.tar.gz
gst-plugins-bad-ef2cb71d5fcad4dc3cbc239368a7bb9c30206761.tar.bz2
gst-plugins-bad-ef2cb71d5fcad4dc3cbc239368a7bb9c30206761.zip
Add an OFA element, the successor of MusicBrainz TRM fingerprinting.
Original commit message from CVS: Based on a patch by: Eric Buehl <eric dot buehl at gmail dot com> * configure.ac: * ext/ofa/Makefile.am: * ext/ofa/gstofa.c: (gst_ofa_base_init), (gst_ofa_finalize), (gst_ofa_class_init), (create_fingerprint), (gst_ofa_event), (gst_ofa_init), (gst_ofa_transform_ip), (gst_ofa_get_property), (plugin_init): * ext/ofa/gstofa.h: Add an OFA element, the successor of MusicBrainz TRM fingerprinting. Fixes bug #351309.
Diffstat (limited to 'ext/ofa/Makefile.am')
-rw-r--r--ext/ofa/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/ext/ofa/Makefile.am b/ext/ofa/Makefile.am
new file mode 100644
index 00000000..346ec8d8
--- /dev/null
+++ b/ext/ofa/Makefile.am
@@ -0,0 +1,18 @@
+plugin_LTLIBRARIES = libgstofa.la
+
+libgstofa_la_SOURCES = gstofa.c
+
+libgstofa_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(OFA_CFLAGS)
+
+libgstofa_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(OFA_LIBS)
+
+libgstofa_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstofa.h