summaryrefslogtreecommitdiffstats
path: root/ext/resindvd/Makefile.am
diff options
context:
space:
mode:
authorJan Schmidt <thaytan@mad.scientist.com>2008-07-11 14:06:08 +0000
committerJan Schmidt <thaytan@mad.scientist.com>2008-07-11 14:06:08 +0000
commit9a392ef442ef284f63c36ef3690445e5938a046a (patch)
treef648a0b8f712c94cfd1dd8a3c4cd373477b560f5 /ext/resindvd/Makefile.am
parentf79bf9a0fba0c37de0734fd618bbfc499889facf (diff)
downloadgst-plugins-bad-9a392ef442ef284f63c36ef3690445e5938a046a.tar.gz
gst-plugins-bad-9a392ef442ef284f63c36ef3690445e5938a046a.tar.bz2
gst-plugins-bad-9a392ef442ef284f63c36ef3690445e5938a046a.zip
docs/plugins/.cvsignore: Ignore *-undeclared.txt
Original commit message from CVS: * docs/plugins/.cvsignore: Ignore *-undeclared.txt * ext/resindvd/rsnaudiomunge.c: Turn g_print's into debug statements. * ext/resindvd/resin-play: * ext/resindvd/Makefile.am: * ext/resindvd/resindvdbin.c: * ext/resindvd/resindvdbin.h: * ext/resindvd/rsnparsetter.c: * ext/resindvd/rsnparsetter.h: * ext/resindvd/rsnwrappedbuffer.c: * ext/resindvd/rsnwrappedbuffer.h: Add a bloated implementation of a really simple idea: Replace the pixel-aspect-ratio in the output video with a prescribed one when necessary. There must be an easier way. Split the dvdspu out of the resindvdbin and put out the subpicture stream on the subpicture pad. * ext/resindvd/gstmpegdemux.c: Send video-aspect events down the pipe from the demuxer. * ext/resindvd/resindvdsrc.c: * ext/resindvd/resindvdsrc.h: Handle timed-stills somewhat using g_cond_timed_wait, with a FIXME to make it use clock-waiting later. * ext/resindvd/rsnbasesrc.c: Don't overwrite the last_stop in the basesrc segment after a seamless seek.
Diffstat (limited to 'ext/resindvd/Makefile.am')
-rw-r--r--ext/resindvd/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/ext/resindvd/Makefile.am b/ext/resindvd/Makefile.am
index 9f4d3c8f..ace8fc33 100644
--- a/ext/resindvd/Makefile.am
+++ b/ext/resindvd/Makefile.am
@@ -12,10 +12,12 @@ libresindvd_la_SOURCES = \
resindvdsrc.c \
gstmpegdesc.c \
gstmpegdemux.c \
- gstpesfilter.c
+ gstpesfilter.c \
+ rsnparsetter.c \
+ rsnwrappedbuffer.c
-libresindvd_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(DVDNAV_CFLAGS)
-libresindvd_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
+libresindvd_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(DVDNAV_CFLAGS)
+libresindvd_la_LIBADD = $(GST_PLUGINS_BASE_CFLAGS) -lgstvideo-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
libresindvd_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = resindvdbin.h \
@@ -27,4 +29,5 @@ noinst_HEADERS = resindvdbin.h \
gstmpegdefs.h \
gstmpegdesc.h \
gstmpegdemux.h \
- gstpesfilter.h
+ gstpesfilter.h \
+ rsnparsetter.h