summaryrefslogtreecommitdiffstats
path: root/ext/schroedinger/Makefile.am
diff options
context:
space:
mode:
authorDave Robillard <dave@drobilla.net>2009-07-03 20:01:30 -0400
committerDave Robillard <dave@drobilla.net>2009-07-03 20:01:30 -0400
commitcaba48f261421d397900471b19350da2e5a4a4e5 (patch)
treeace87e1bd5c819454aefaa722203c30ed83f4ec1 /ext/schroedinger/Makefile.am
parent699e4f4d044d8111053b631baba4b324a60b1274 (diff)
parent6a763f6a471e9fbbd86358b0175498a6af78666e (diff)
downloadgst-plugins-bad-caba48f261421d397900471b19350da2e5a4a4e5.tar.gz
gst-plugins-bad-caba48f261421d397900471b19350da2e5a4a4e5.tar.bz2
gst-plugins-bad-caba48f261421d397900471b19350da2e5a4a4e5.zip
Merge branch 'master' of git://anongit.freedesktop.org/gstreamer/gst-plugins-bad into fdo
Diffstat (limited to 'ext/schroedinger/Makefile.am')
-rw-r--r--ext/schroedinger/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/ext/schroedinger/Makefile.am b/ext/schroedinger/Makefile.am
new file mode 100644
index 00000000..6a895c51
--- /dev/null
+++ b/ext/schroedinger/Makefile.am
@@ -0,0 +1,28 @@
+
+plugin_LTLIBRARIES = libgstschro.la
+
+noinst_HEADERS = \
+ gstschroutils.h
+
+libgstschro_la_SOURCES = \
+ gstschro.c \
+ gstschrodec.c \
+ gstschroenc.c \
+ gstschroparse.c \
+ gstschroutils.c
+libgstschro_la_CFLAGS = \
+ $(GST_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ -DGST_USE_UNSTABLE_API \
+ $(SCHRO_CFLAGS)
+libgstschro_la_LIBADD = \
+ $(GST_LIBS) \
+ $(GST_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ \
+ $(top_builddir)/gst-libs/gst/video/libgstbasevideo-@GST_MAJORMINOR@.la \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(SCHRO_LIBS)
+libgstschro_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstschro_la_LIBTOOLFLAGS = --tag=disable-static
+
+