summaryrefslogtreecommitdiffstats
path: root/ext/schroedinger/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2009-07-01 10:55:12 -0700
committerDavid Schleef <ds@schleef.org>2009-07-01 10:56:24 -0700
commitcf2b2b017f0995ecab2822804537f193835e35e9 (patch)
treeadeebf611c5f618ec4faa197385cab8eb368b0ce /ext/schroedinger/Makefile.am
parent80856964b52a089d5d286fd1543b89d2a3ea4a39 (diff)
downloadgst-plugins-bad-cf2b2b017f0995ecab2822804537f193835e35e9.tar.gz
gst-plugins-bad-cf2b2b017f0995ecab2822804537f193835e35e9.tar.bz2
gst-plugins-bad-cf2b2b017f0995ecab2822804537f193835e35e9.zip
basevideo: move from -base
Also move schroedinger plugin. This creates a new library, gstbasevideo-0.10, which will probably be merged back into gstvideo-0.10 when this is moved back to -base.
Diffstat (limited to 'ext/schroedinger/Makefile.am')
-rw-r--r--ext/schroedinger/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/ext/schroedinger/Makefile.am b/ext/schroedinger/Makefile.am
new file mode 100644
index 00000000..23869243
--- /dev/null
+++ b/ext/schroedinger/Makefile.am
@@ -0,0 +1,27 @@
+
+plugin_LTLIBRARIES = libgstschro.la
+
+noinst_HEADERS = \
+ gstschroutils.h
+
+libgstschro_la_SOURCES = \
+ gstschro.c \
+ gstschrodec.c \
+ gstschroenc.c \
+ gstschroparse.c \
+ gstschroutils.c
+libgstschro_la_CFLAGS = \
+ $(GST_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(SCHRO_CFLAGS)
+libgstschro_la_LIBADD = \
+ $(GST_LIBS) \
+ $(GST_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ \
+ $(top_builddir)/gst-libs/gst/video/libgstbasevideo-@GST_MAJORMINOR@.la \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(SCHRO_LIBS)
+libgstschro_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstschro_la_LIBTOOLFLAGS = --tag=disable-static
+
+