summaryrefslogtreecommitdiffstats
path: root/ext/sdl/Makefile.am
diff options
context:
space:
mode:
authorEdgard Lima <edgard.lima@indt.org.br>2006-01-09 18:20:56 +0000
committerEdgard Lima <edgard.lima@indt.org.br>2006-01-09 18:20:56 +0000
commita438034608c14b446943fcc0fbb0fa04df93aa47 (patch)
tree765d96dbb8f9f3711cae0183c945612f09a84071 /ext/sdl/Makefile.am
parentce77e3b44bc291c54039918f2136dff8b44a4c9f (diff)
downloadgst-plugins-bad-a438034608c14b446943fcc0fbb0fa04df93aa47.tar.gz
gst-plugins-bad-a438034608c14b446943fcc0fbb0fa04df93aa47.tar.bz2
gst-plugins-bad-a438034608c14b446943fcc0fbb0fa04df93aa47.zip
Created new element, sdlaudiosink.
Original commit message from CVS: Created new element, sdlaudiosink.
Diffstat (limited to 'ext/sdl/Makefile.am')
-rw-r--r--ext/sdl/Makefile.am19
1 files changed, 15 insertions, 4 deletions
diff --git a/ext/sdl/Makefile.am b/ext/sdl/Makefile.am
index c183ee80..24e6d985 100644
--- a/ext/sdl/Makefile.am
+++ b/ext/sdl/Makefile.am
@@ -1,8 +1,19 @@
plugin_LTLIBRARIES = libgstsdlvideosink.la
-libgstsdlvideosink_la_SOURCES = sdlvideosink.c
-libgstsdlvideosink_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(SDL_CFLAGS)
-libgstsdlvideosink_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR) $(SDL_LIBS)
+libgstsdlvideosink_la_SOURCES = gstsdl.c \
+ sdlvideosink.c \
+ sdlaudiosink.c
+
+libgstsdlvideosink_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) \
+ $(SDL_CFLAGS)
+
+libgstsdlvideosink_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) \
+ -lgstvideo-$(GST_MAJORMINOR) \
+ -lgstaudio-@GST_MAJORMINOR@ \
+ -lgstinterfaces-$(GST_MAJORMINOR) \
+ $(SDL_LIBS)
+
libgstsdlvideosink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-noinst_HEADERS = sdlvideosink.h
+noinst_HEADERS = sdlvideosink.h \
+ sdlaudiosink.h