summaryrefslogtreecommitdiffstats
path: root/ext/sndfile/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2003-06-16 14:56:34 +0000
committerAndy Wingo <wingo@pobox.com>2003-06-16 14:56:34 +0000
commit4a65aa251d81e2bb41a7d960b7adb66301459055 (patch)
tree903a6cf83a314022c8ed5436de2a76d0666c6102 /ext/sndfile/Makefile.am
parentc7cc73bfaa01e3b9cc5a35cb52b626b770fb31b6 (diff)
downloadgst-plugins-bad-4a65aa251d81e2bb41a7d960b7adb66301459055.tar.gz
gst-plugins-bad-4a65aa251d81e2bb41a7d960b7adb66301459055.tar.bz2
gst-plugins-bad-4a65aa251d81e2bb41a7d960b7adb66301459055.zip
caps refcounting fixes for float2int fixed wrt setting of caps on int pad with dynamic number of sink pads in float2i...
Original commit message from CVS: * caps refcounting fixes for float2int * fixed wrt setting of caps on int pad with dynamic number of sink pads in float2int * added libsndfile plugin (currently only the src is implemented) - currently only float output, noninterleaved is implemented
Diffstat (limited to 'ext/sndfile/Makefile.am')
-rw-r--r--ext/sndfile/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ext/sndfile/Makefile.am b/ext/sndfile/Makefile.am
new file mode 100644
index 00000000..deeee5a3
--- /dev/null
+++ b/ext/sndfile/Makefile.am
@@ -0,0 +1,10 @@
+plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+
+plugin_LTLIBRARIES = libgstsndfile.la
+
+libgstsndfile_la_SOURCES = gstsf.c
+libgstsndfile_la_CFLAGS = $(GST_CFLAGS) $(SNDFILE_CFLAGS)
+libgstsndfile_la_LIBADD = $(SNDFILE_LIBS)
+libgstsndfile_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstsf.h