summaryrefslogtreecommitdiffstats
path: root/ext/soundtouch/Makefile.am
diff options
context:
space:
mode:
authorWouter Paeson <wouter@kangaroot.net>2006-03-22 14:31:47 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-03-22 14:31:47 +0000
commit89ab6598cb6e3469e04811047f3d0cab78857b91 (patch)
treeb67aca1c461a3ebfbd8e32a6854de81d9c3caa97 /ext/soundtouch/Makefile.am
parent2fd4b22a8367f75995501822e772055ef8318d82 (diff)
downloadgst-plugins-bad-89ab6598cb6e3469e04811047f3d0cab78857b91.tar.gz
gst-plugins-bad-89ab6598cb6e3469e04811047f3d0cab78857b91.tar.bz2
gst-plugins-bad-89ab6598cb6e3469e04811047f3d0cab78857b91.zip
Add new libsoundtouch-based pitch plugin (#331335).
Original commit message from CVS: Patch by: Wouter Paeson <wouter at kangaroot dot net> * configure.ac: * ext/Makefile.am: * ext/soundtouch/Makefile.am: * ext/soundtouch/gstpitch.cc: * ext/soundtouch/gstpitch.hh: Add new libsoundtouch-based pitch plugin (#331335).
Diffstat (limited to 'ext/soundtouch/Makefile.am')
-rw-r--r--ext/soundtouch/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/ext/soundtouch/Makefile.am b/ext/soundtouch/Makefile.am
new file mode 100644
index 00000000..d286bfce
--- /dev/null
+++ b/ext/soundtouch/Makefile.am
@@ -0,0 +1,9 @@
+plugin_LTLIBRARIES = libgstpitch.la
+
+libgstpitch_la_SOURCES = gstpitch.cc
+
+libgstpitch_la_CXXFLAGS = @GST_CFLAGS@ @GST_BASE_CFLAGS@ @SOUNDTOUCH_CFLAGS@
+libgstpitch_la_LIBADD = @GST_LIBS@ @GST_BASE_LIBS@ @SOUNDTOUCH_LIBS@
+libgstpitch_la_LDFLAGS = @GST_PLUGIN_LDFLAGS@
+
+noinst_HEADERS = gstpitch.hh