summaryrefslogtreecommitdiffstats
path: root/ext/spc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2009-08-08 21:17:37 +0200
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2009-08-08 21:20:30 +0200
commit8ad3f148734f6f5b89dcb84157f5cc083956f7eb (patch)
tree269784b25dfa134de9796c600aec7ebbe42220a8 /ext/spc/Makefile.am
parent24217ee31a5030f528e13a94233580e86d70baf0 (diff)
downloadgst-plugins-bad-8ad3f148734f6f5b89dcb84157f5cc083956f7eb.tar.gz
gst-plugins-bad-8ad3f148734f6f5b89dcb84157f5cc083956f7eb.tar.bz2
gst-plugins-bad-8ad3f148734f6f5b89dcb84157f5cc083956f7eb.zip
spc: Add the OpenSPC spc plugin again
The gme plugin obsoletes it but it might still be useful for users that don't have gme yet or prefer openspc for some reason.
Diffstat (limited to 'ext/spc/Makefile.am')
-rw-r--r--ext/spc/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/ext/spc/Makefile.am b/ext/spc/Makefile.am
new file mode 100644
index 00000000..067ea669
--- /dev/null
+++ b/ext/spc/Makefile.am
@@ -0,0 +1,11 @@
+plugin_LTLIBRARIES = libgstspc.la
+
+libgstspc_la_SOURCES = gstspc.c tag.c
+
+libgstspc_la_CFLAGS = $(GST_CFLAGS) $(SPC_CFLAGS)
+libgstspc_la_LIBADD = $(GST_LIBS) $(SPC_LIBS)
+libgstspc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstspc_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstspc.h tag.h
+