summaryrefslogtreecommitdiffstats
path: root/ext/spc/Makefile.am
diff options
context:
space:
mode:
authorChris Lee <clee@kde.org>2006-07-23 11:52:34 +0000
committerTim-Philipp Müller <tim@centricular.net>2006-07-23 11:52:34 +0000
commitb7f35a1240ff5ff5ccdfceb4730242f1714d9a18 (patch)
tree59a1a9842015ee2c1b01f50b33a10cb648e0606e /ext/spc/Makefile.am
parentc8e459496b315ada563c65c0703e574b5913e849 (diff)
downloadgst-plugins-bad-b7f35a1240ff5ff5ccdfceb4730242f1714d9a18.tar.gz
gst-plugins-bad-b7f35a1240ff5ff5ccdfceb4730242f1714d9a18.tar.bz2
gst-plugins-bad-b7f35a1240ff5ff5ccdfceb4730242f1714d9a18.zip
Add libopenspc-based SPC decoder element (#348220).
Original commit message from CVS: Patch by: Chris Lee <clee at kde org> * configure.ac: * ext/Makefile.am: * ext/spc/Makefile.am: * ext/spc/gstspc.c: (spc_negotiate), (gst_spc_dec_base_init), (gst_spc_dec_class_init), (gst_spc_dec_init), (gst_spc_dec_chain), (gst_spc_dec_sink_event), (gst_spc_dec_src_event), (gst_spc_dec_src_query), (spc_play), (spc_setup), (gst_spc_dec_change_state), (plugin_init): * ext/spc/gstspc.h: Add libopenspc-based SPC decoder element (#348220).
Diffstat (limited to 'ext/spc/Makefile.am')
-rw-r--r--ext/spc/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/ext/spc/Makefile.am b/ext/spc/Makefile.am
new file mode 100644
index 00000000..18a878b2
--- /dev/null
+++ b/ext/spc/Makefile.am
@@ -0,0 +1,9 @@
+plugin_LTLIBRARIES = libgstspc.la
+
+libgstspc_la_SOURCES = gstspc.c
+
+libgstspc_la_CFLAGS = $(GST_CFLAGS) $(SPC_CFLAGS)
+libgstspc_la_LIBADD = $(GST_LIBS) $(SPC_LIBS)
+libgstspc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstspc.h