summaryrefslogtreecommitdiffstats
path: root/ext/x264/Makefile.am
diff options
context:
space:
mode:
authorStefan Kost <ensonic@users.sf.net>2009-04-30 00:06:36 +0300
committerDave Robillard <dave@drobilla.net>2009-05-03 12:03:19 -0400
commit3ad6e285751aff21a2aae2ef5d33e0ec6c9eb46f (patch)
treefce5a5ab76ab343dace0665c8e886e12cdb9a892 /ext/x264/Makefile.am
parentd71386a0337c1c1aba1a88ba5108f28d54f62768 (diff)
downloadgst-plugins-bad-3ad6e285751aff21a2aae2ef5d33e0ec6c9eb46f.tar.gz
gst-plugins-bad-3ad6e285751aff21a2aae2ef5d33e0ec6c9eb46f.tar.bz2
gst-plugins-bad-3ad6e285751aff21a2aae2ef5d33e0ec6c9eb46f.zip
x264enc: add preset support
Add preset iface and a (dummy) preset file as a starting point.
Diffstat (limited to 'ext/x264/Makefile.am')
-rw-r--r--ext/x264/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/ext/x264/Makefile.am b/ext/x264/Makefile.am
index 891e3fca..6c4d4cf6 100644
--- a/ext/x264/Makefile.am
+++ b/ext/x264/Makefile.am
@@ -13,3 +13,9 @@ libgstx264_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstx264_la_LIBTOOLFLAGS = --tag=disable-static
noinst_HEADERS = gstx264enc.h
+
+presetdir = $(datadir)/gstreamer-$(GST_MAJORMINOR)/presets
+preset_DATA = GstX264Enc.prs
+
+EXTRA_DIST = $(preset_DATA)
+