summaryrefslogtreecommitdiffstats
path: root/ext/x264/Makefile.am
diff options
context:
space:
mode:
authorMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-08-08 14:19:16 +0000
committerMark Nauwelaerts <mark.nauwelaerts@collabora.co.uk>2008-08-08 14:19:16 +0000
commit624612a9ca7a956ff65db71128e7e3eda9068490 (patch)
tree5dcc514af983f63736395a3b95e06f9ebb6eb2b5 /ext/x264/Makefile.am
parent18d7934ae35b88eaf80551d17d3e1be9874ee7c5 (diff)
downloadgst-plugins-bad-624612a9ca7a956ff65db71128e7e3eda9068490.tar.gz
gst-plugins-bad-624612a9ca7a956ff65db71128e7e3eda9068490.tar.bz2
gst-plugins-bad-624612a9ca7a956ff65db71128e7e3eda9068490.zip
ext/x264/: Use GQueue in stead of custom queue code.
Original commit message from CVS: * ext/x264/Makefile.am: * ext/x264/gstx264enc.c: (gst_x264_enc_set_src_caps), (gst_x264_enc_sink_set_caps), (gst_x264_enc_init), (gst_x264_enc_reset), (gst_x264_enc_finalize), (gst_x264_enc_flush_frames), (gst_x264_enc_sink_event), (gst_x264_enc_chain), (gst_x264_enc_encode_frame), (gst_x264_enc_change_state), (gst_x264_enc_set_property): * ext/x264/gstx264enc.h: Use GQueue in stead of custom queue code. Factorize flushing out encoder delayed frames. Factorize initialization and state change reset.
Diffstat (limited to 'ext/x264/Makefile.am')
-rw-r--r--ext/x264/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/ext/x264/Makefile.am b/ext/x264/Makefile.am
index 4369f46b..fd664ede 100644
--- a/ext/x264/Makefile.am
+++ b/ext/x264/Makefile.am
@@ -1,9 +1,14 @@
plugin_LTLIBRARIES = libgstx264.la
libgstx264_la_SOURCES = gstx264enc.c
-libgstx264_la_CFLAGS = $(X264_CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
-libgstx264_la_LIBADD = $(X264_LIBS) $(GST_LIBS) $(GST_PLUGINS_BASE_LIBS) \
- -lgstvideo-$(GST_MAJORMINOR)
+libgstx264_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(X264_CFLAGS)
+libgstx264_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) \
+ $(GST_LIBS) \
+ $(X264_LIBS)
libgstx264_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = gstx264enc.h