summaryrefslogtreecommitdiffstats
path: root/ext/xine/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@gnome.org>2004-02-20 00:52:07 +0000
committerBenjamin Otte <otte@gnome.org>2004-02-20 00:52:07 +0000
commitea5845cb2bfdb57a06cc2ad5b2561889b5fcc049 (patch)
tree9dda208cfb8b9d268abb43c3ac4fb09c3666ca73 /ext/xine/Makefile.am
parentfd2dd2337b1b5e466540337dac79a69a560f6eb4 (diff)
downloadgst-plugins-bad-ea5845cb2bfdb57a06cc2ad5b2561889b5fcc049.tar.gz
gst-plugins-bad-ea5845cb2bfdb57a06cc2ad5b2561889b5fcc049.tar.bz2
gst-plugins-bad-ea5845cb2bfdb57a06cc2ad5b2561889b5fcc049.zip
ext/xine/: add first version of xine plugin wrapper. Currently only wraps the
Original commit message from CVS: 2004-02-20 Benjamin Otte <otte@gnome.org> * ext/xine/Makefile.am: * ext/xine/gstxine.h: * ext/xine/xine.c: * ext/xine/xineaudiodec.c: * ext/xine/xinecaps.c: add first version of xine plugin wrapper. Currently only wraps the QDM2 win32 DLL, and even that only in proof-of-concept quality. * configure.ac: * ext/Makefile.am: add xine plugin wrapper, disabled by default. Use --enable-xine to build. Note that it'll segfault on gst-register if you don't remove the goom and tvtime post plugins from xine. * gst/qtdemux/qtdemux.c: (gst_qtdemux_handle_sink_event), (qtdemux_parse), (qtdemux_parse_trak), (qtdemux_audio_caps): add extradata parsing for QDM2. change around debugging prints.
Diffstat (limited to 'ext/xine/Makefile.am')
-rw-r--r--ext/xine/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/ext/xine/Makefile.am b/ext/xine/Makefile.am
new file mode 100644
index 00000000..b67889c7
--- /dev/null
+++ b/ext/xine/Makefile.am
@@ -0,0 +1,11 @@
+plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+
+plugin_LTLIBRARIES = libgstxine.la
+
+libgstxine_la_SOURCES = xine.c xinecaps.c xineaudiodec.c
+libgstxine_la_CFLAGS = $(GST_CFLAGS) $(XINE_CFLAGS)
+libgstxine_la_LIBADD = $(XINE_LIBS)
+libgstxine_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstxine.h
+