summaryrefslogtreecommitdiffstats
path: root/ext/xvid/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-21 21:54:27 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-04-21 21:54:27 +0000
commitab57fbcd544e5226cb57aef7d54370f58e8badf4 (patch)
treec6f10a198cf57b4279b82ecb41069f66fd13ee9e /ext/xvid/Makefile.am
parent7ca8563737c8a87cdd54bb2aefe8321354c5362e (diff)
downloadgst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.tar.gz
gst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.tar.bz2
gst-plugins-bad-ab57fbcd544e5226cb57aef7d54370f58e8badf4.zip
Adds divx/xvid encoders. divx encoder is based on divx4linux (commercial, closed-source)
Original commit message from CVS: Adds divx/xvid encoders. * divx encoder is based on divx4linux (commercial, closed-source) * xvid encoder is based on xvidcore (http://www.xvid.org/, GPL - Christian? ;) ) Both use a GstCaps that doesn't conform with what we currently use, I might fix that later on or so. For now, it doesn't matter, it's just a test. We're also missing corresponding decoders (ffmpeg can decoded this too, but that's not the point), these might come later too.
Diffstat (limited to 'ext/xvid/Makefile.am')
-rw-r--r--ext/xvid/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ext/xvid/Makefile.am b/ext/xvid/Makefile.am
new file mode 100644
index 00000000..267b1ccc
--- /dev/null
+++ b/ext/xvid/Makefile.am
@@ -0,0 +1,10 @@
+plugindir = $(libdir)/gstreamer-@GST_MAJORMINOR@
+
+plugin_LTLIBRARIES = libgstxvid.la
+
+libgstxvid_la_SOURCES = gstxvidenc.c
+libgstxvid_la_CFLAGS = $(GST_CFLAGS) $(XVID_CFLAGS)
+libgstxvid_la_LIBADD = $(XVID_LIBS)
+libgstxvid_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstxvidenc.h