summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/colorbalance/Makefile.am
diff options
context:
space:
mode:
authorRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-07 12:11:30 +0000
committerRonald S. Bultje <rbultje@ronald.bitfreak.net>2003-12-07 12:11:30 +0000
commit9bda5831b8818d0fe4286fdb1217085913277c0d (patch)
tree404583dd41a644b2e2dd72aa587357b252c135d8 /gst-libs/gst/colorbalance/Makefile.am
parentef074394e68785508b4def25078ffaba572cb0c8 (diff)
downloadgst-plugins-bad-9bda5831b8818d0fe4286fdb1217085913277c0d.tar.gz
gst-plugins-bad-9bda5831b8818d0fe4286fdb1217085913277c0d.tar.bz2
gst-plugins-bad-9bda5831b8818d0fe4286fdb1217085913277c0d.zip
Move over from GstInterface to GstImplementsInterface. Also adds some signals to several interfaces
Original commit message from CVS: Move over from GstInterface to GstImplementsInterface. Also adds some signals to several interfaces
Diffstat (limited to 'gst-libs/gst/colorbalance/Makefile.am')
-rw-r--r--gst-libs/gst/colorbalance/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/gst-libs/gst/colorbalance/Makefile.am b/gst-libs/gst/colorbalance/Makefile.am
index dc8bd0ea..b1f6bec4 100644
--- a/gst-libs/gst/colorbalance/Makefile.am
+++ b/gst-libs/gst/colorbalance/Makefile.am
@@ -9,5 +9,23 @@ noinst_LTLIBRARIES = libgstcolorbalance.la
libgstcolorbalance_la_SOURCES = \
colorbalance.c \
- colorbalancechannel.c
+ colorbalancechannel.c \
+ colorbalancemarshal.c
libgstcolorbalance_la_CFLAGS = $(GST_CFLAGS) $(GST_OPT_CFLAGS)
+
+BUILT_SOURCES = \
+ colorbalancemarshal.c \
+ colorbalancemarshal.h
+built_headers = \
+ colorbalancemarshal.h
+
+EXTRA_DIST = colorbalancemarshal.list
+
+colorbalancemarshal.h: colorbalancemarshal.list
+ glib-genmarshal --header --prefix=gst_color_balance_marshal $^ > colorbalancemarshal.h.tmp
+ mv colorbalancemarshal.h.tmp colorbalancemarshal.h
+
+colorbalancemarshal.c: colorbalancemarshal.list
+ echo "#include \"colorbalancemarshal.h\"" >> colorbalancemarshal.c.tmp
+ glib-genmarshal --body --prefix=gst_color_balance_marshal $^ >> colorbalancemarshal.c.tmp
+ mv colorbalancemarshal.c.tmp colorbalancemarshal.c