summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/interfaces/Makefile.am
diff options
context:
space:
mode:
authorNokia Corporation <multimedia@maemo.org>2009-02-06 12:06:23 +0200
committerRené Stadler <rene.stadler@nokia.com>2009-02-09 10:22:08 +0200
commitf081d3e7b6db4d4e20cc658a192cbbfbceaea9af (patch)
treef21cb5077bc96ce0205066360cb151573a205859 /gst-libs/gst/interfaces/Makefile.am
parentdc408bb28bbcaa8e879ced16c5ee0007c1c54cf3 (diff)
downloadgst-plugins-bad-f081d3e7b6db4d4e20cc658a192cbbfbceaea9af.tar.gz
gst-plugins-bad-f081d3e7b6db4d4e20cc658a192cbbfbceaea9af.tar.bz2
gst-plugins-bad-f081d3e7b6db4d4e20cc658a192cbbfbceaea9af.zip
Add photography interface.
Diffstat (limited to 'gst-libs/gst/interfaces/Makefile.am')
-rw-r--r--gst-libs/gst/interfaces/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/gst-libs/gst/interfaces/Makefile.am b/gst-libs/gst/interfaces/Makefile.am
new file mode 100644
index 00000000..5b6977fc
--- /dev/null
+++ b/gst-libs/gst/interfaces/Makefile.am
@@ -0,0 +1,41 @@
+lib_LTLIBRARIES = libgstphotography-@GST_MAJORMINOR@.la
+libgstphotographyincludedir = \
+ $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/interfaces
+
+headers_photography = \
+ photography.h
+
+# variables used for enum/marshal generation
+glib_enum_headers=$(headers_photography)
+glib_enum_define=GST_PHOTOGRAPHY
+glib_enum_prefix=gst_photography
+
+built_sources = \
+ photography-enumtypes.c
+
+built_headers = \
+ photography-enumtypes.h
+
+libgstphotographyinclude_HEADERS = \
+ $(headers_photography)
+
+nodist_libgstphotographyinclude_HEADERS = \
+ photography-enumtypes.h
+
+libgstphotography_@GST_MAJORMINOR@_la_SOURCES = \
+ photography.c
+
+nodist_libgstphotography_@GST_MAJORMINOR@_la_SOURCES = \
+ $(built_sources)
+
+libgstphotography_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS)
+libgstphotography_@GST_MAJORMINOR@_la_LIBADD = $(GST_LIBS)
+libgstphotography_@GST_MAJORMINOR@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_ALL_LDFLAGS) $(GST_LT_LDFLAGS)
+
+BUILT_SOURCES = \
+ $(built_sources) \
+ $(built_headers)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+include $(top_srcdir)/common/glib-gen.mak