summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/tuner/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2004-02-03 20:20:07 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2004-02-03 20:20:07 +0000
commit47be812c27b5d8ecc37a1a89eec18a1e33dc9320 (patch)
treee4e017a021025a1bdf95d67abca2b8913fe6f5b7 /gst-libs/gst/tuner/Makefile.am
parent4c0511c1dfe5915c3d2395fd754ad13c6a278f49 (diff)
downloadgst-plugins-bad-47be812c27b5d8ecc37a1a89eec18a1e33dc9320.tar.gz
gst-plugins-bad-47be812c27b5d8ecc37a1a89eec18a1e33dc9320.tar.bz2
gst-plugins-bad-47be812c27b5d8ecc37a1a89eec18a1e33dc9320.zip
remove glib_root add hack rule for .Plo files
Original commit message from CVS: remove glib_root add hack rule for .Plo files
Diffstat (limited to 'gst-libs/gst/tuner/Makefile.am')
-rw-r--r--gst-libs/gst/tuner/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/gst-libs/gst/tuner/Makefile.am b/gst-libs/gst/tuner/Makefile.am
index af1020fa..ebfca95e 100644
--- a/gst-libs/gst/tuner/Makefile.am
+++ b/gst-libs/gst/tuner/Makefile.am
@@ -1,7 +1,6 @@
# variables used for enum/marshal generation
glib_enum_headers=$(tuner_headers)
glib_enum_define=GST_TUNER
-glib_root=tuner
glib_enum_prefix=gst_tuner
libgsttunerincludedir = \
@@ -12,9 +11,13 @@ tuner_headers = \
tunernorm.h \
tunerchannel.h
+built_sources = \
+ tuner-marshal.c \
+ tuner-enumtypes.c
+
built_headers = \
- $(glib_root)-marshal.h \
- $(glib_root)-enumtypes.h
+ tuner-marshal.h \
+ tuner-enumtypes.h
libgsttunerinclude_HEADERS = $(tuner_headers) $(built_headers)
@@ -24,16 +27,15 @@ libgsttuner_la_SOURCES = \
tuner.c \
tunernorm.c \
tunerchannel.c \
- $(glib_root)-marshal.c
+ $(built_sources)
libgsttuner_la_CFLAGS = $(GST_CFLAGS)
BUILT_SOURCES = \
- $(glib_root)-marshal.c \
- $(glib_root)-enumtypes.c \
+ $(built_sources) \
$(built_headers)
-EXTRA_DIST = $(glib_root)-marshal.list
+EXTRA_DIST = tuner-marshal.list
CLEANFILES = $(BUILT_SOURCES)